3

I ran this command in Terminal, which supposedly clears all duplicate applications from the "Open With…" menu and now many of my files are just showing up as blank images (.zip files, .dmg files, .rar, etc.) and they don't open with the correct application. I did log out and log back in after doing this. Help!!

/System/Library/Frameworks/CoreServices.framework/Versions/A/Frameworks/LaunchServices.framework/Versions/A/Support/lsregister -kill -r -domain user

6

Logout and then Login.

It's common for this to happen. If the problem doesn't fix itself upon logging back in it's just a matter of Rebuilding the Launch Services.

Try it this way:

/System/Library/Frameworks/CoreServices.framework/Frameworks/LaunchServices.framework/Support/lsregister -kill -r -domain local -domain system -domain user

Alternatively, you can use the commercial utility MacPilot:

enter image description here

2
  • Ah...thank you SOOO much!!! This worked (running lsregister with the commands you specified)!!! – daviesgeek Aug 20 '11 at 21:01
  • Your welcome! I'm glad I could help. ;-) – l'L'l Aug 20 '11 at 21:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .