This is my first OS X experience so I'm not sure what to do other than ask you guys. I can get PyCharm to install, or so it seems, but when I try to run it all that happens is:

  1. the icon shows up on the dock
  2. a window pops up and asks me if I want to run it, I confirm
  3. and then the icon disappears. It just shrinks away.

I've searched for this but I can't find anyone talking about this problem.
Once the icon goes away, nothing else happens.
I'm on a MacBook running Snow Leopard 10.6.8

This is the output from console after running Pycharm.

2/7/16 10:55:32 AM  pycharm[374]    Value of PYCHARM_JDK: (null)
2/7/16 10:55:32 AM  pycharm[374]    fullFileName is: /Applications/PyCharm CE.app/Contents/bin/pycharm.vmoptions
2/7/16 10:55:32 AM  pycharm[374]    fullFileName exists: /Applications/PyCharm CE.app/Contents/bin/pycharm.vmoptions
2/7/16 10:55:32 AM  pycharm[374]    Value of PYCHARM_VM_OPTIONS is (null)
2/7/16 10:55:32 AM  pycharm[374]    Processing VMOptions file at /Applications/PyCharm CE.app/Contents/bin/pycharm.vmoptions
2/7/16 10:55:32 AM  pycharm[374]    Done
2/7/16 10:55:33 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]    /Applications/PyCharm CE.app/Contents/bin/idea.properties: 'java.endorsed.dirs' already defined
2/7/16 10:55:34 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]    Start Failed: Internal error. Please report to http://jb.gg/ide/critical-startup-errors
2/7/16 10:55:34 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]    java.lang.reflect.InvocationTargetException
2/7/16 10:55:34 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]        at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
2/7/16 10:55:34 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]        at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:62)
2/7/16 10:55:34 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]        at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:43)
2/7/16 10:55:34 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]        at java.lang.reflect.Method.invoke(Method.java:497)
2/7/16 10:55:34 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]        at com.intellij.ide.Bootstrap.main(Bootstrap.java:39)
2/7/16 10:55:34 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]        at com.intellij.idea.Main.main(Main.java:91)
2/7/16 10:55:34 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]    Caused by: java.lang.UnsatisfiedLinkError: /Applications/PyCharm CE.app/Contents/jre/jdk/Contents/Home/jre/lib/libawt_lwawt.dylib: dlopen(/Applications/PyCharm CE.app/Contents/jre/jdk/Contents/Home/jre/lib/libawt_lwawt.dylib, 1): Symbol not found: _JNFRunLoopDidStartNotification
2/7/16 10:55:34 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]      Referenced from: /Applications/PyCharm CE.app/Contents/jre/jdk/Contents/Home/jre/lib/./libosxapp.dylib
2/7/16 10:55:34 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]      Expected in: /System/Library/Frameworks/JavaVM.framework/Versions/A/Frameworks/JavaNativeFoundation.framework/Versions/A/JavaNativeFoundation
2/7/16 10:55:34 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]     in /Applications/PyCharm CE.app/Contents/jre/jdk/Contents/Home/jre/lib/./libosxapp.dylib
2/7/16 10:55:34 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]        at java.lang.ClassLoader$NativeLibrary.load(Native Method)
2/7/16 10:55:34 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]        at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1938)
2/7/16 10:55:34 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1821)
2/7/16 10:55:34 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]        at java.lang.Runtime.load0(Runtime.java:809)
2/7/16 10:55:34 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]        at java.lang.System.load(System.java:1086)
2/7/16 10:55:34 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]        at java.lang.ClassLoader$NativeLibrary.load(Native Method)
2/7/16 10:55:34 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]        at java.lang.ClassLoader.loadLibrary0(ClassLoader.java:1938)
2/7/16 10:55:34 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]        at java.lang.ClassLoader.loadLibrary(ClassLoader.java:1842)
2/7/16 10:55:34 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]        at java.lang.Runtime.loadLibrary0(Runtime.java:870)
2/7/16 10:55:34 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]        at java.lang.System.loadLibrary(System.java:1122)
2/7/16 10:55:34 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]        at java.awt.Toolkit$3.run(Toolkit.java:1636)
2/7/16 10:55:34 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]        at java.awt.Toolkit$3.run(Toolkit.java:1634)
2/7/16 10:55:34 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]        at java.security.AccessController.doPrivileged(Native Method)
2/7/16 10:55:34 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]        at java.awt.Toolkit.loadLibraries(Toolkit.java:1633)
2/7/16 10:55:34 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]        at java.awt.Toolkit.<clinit>(Toolkit.java:1668)
2/7/16 10:55:34 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]        at java.awt.Cursor.<clinit>(Cursor.java:195)
2/7/16 10:55:34 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]        at javax.swing.text.html.HTMLEditorKit.<clinit>(HTMLEditorKit.java:623)
2/7/16 10:55:34 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]        at com.intellij.util.ui.UIUtil.<clinit>(UIUtil.java:97)
2/7/16 10:55:34 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]        at com.intellij.ide.plugins.PluginManager.start(PluginManager.java:70)
2/7/16 10:55:34 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]        ... 6 more
2/7/16 10:55:34 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]    Also, an UI exception occurred on attempt to show above message:
2/7/16 10:55:34 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]    java.lang.NoClassDefFoundError: Could not initialize class java.awt.Toolkit
2/7/16 10:55:34 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]        at java.awt.Component.<clinit>(Component.java:593)
2/7/16 10:55:34 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]        at com.intellij.idea.Main.showMessage(Main.java:316)
2/7/16 10:55:34 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]        at com.intellij.idea.Main.showMessage(Main.java:292)
2/7/16 10:55:34 AM  [0x0-0x3b03b].com.jetbrains.pycharm[374]        at com.intellij.idea.Main.main(Main.java:94)
2/7/16 10:55:34 AM  com.apple.launchd.peruser.501[86]   ([0x0-0x3b03b].com.jetbrains.pycharm[374]) Exited with exit code: 3
  • Did you try to completely remove it and then install back? Feb 7 '16 at 16:49
  • Yessir, multiple times. I've tried both the community and professional editions. I also tried running from the .drag screen but it did the same exact thing as if I had dropped it in my apps folder. Feb 7 '16 at 16:51
  • Check what Console says. Application -> Utilities -> Console. Run it and try to start PyCharm again. Feb 7 '16 at 16:53
  • Done, sir. Edited results into the post. Feb 7 '16 at 16:56
  • 1
    Well, I am afraid this will require more deep expertise than I have. May I suggest that you contact PyCharm support for this? jetbrains.com/support Feb 7 '16 at 17:42

I have the same problem, just so you'll know you're not alone. The only solution I found was to invoke pyCharm from the command line, although it then comes up some functionality lacking.

  • Welcome to Ask Different. We like answers to be more than just a single line. Ideally, you want to explain why your answer is *right." It also helps to provide links, citations, and/or screen shots. Please review our help section How to Answer on writing good answers to questions
    – Allan
    May 31 '16 at 20:07

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .