1

For a week now I have been trying to install Windows on my late 2011 MacBook Pro 15". After struggling through the whole installation part (see here), I finally managed to boot into Windows 8.1.

First thing I saw was the Bootcamp drivers installer. The first few times I actually tried running it, but It would always result in a BSOD when trying to install the Intel HD drivers. The BSOD would always say SYSTEM_THREAD_EXCEPTION_NOT_HANDLED (igdkmd64.sys). My Windows installation was broken every time this BSOD occurred (Boots into blackscreen and reboots after 5-10s). I eventually found out that removing the IntelHDLegacyGraphics64.exe file from /BootCamp/Drivers/Intel on my installation device would (temporarily) fix that screen.

With the bootcamp drivers installed (actually without them too, but I couldn't use things like wifi then), I was now finally able to actually boot onto the desktop, but there would always be this little error message from AMD catalyst that there was some kind of error with my graphics drivers. At first, I tried to fix this by going to device manager and updating the drivers of my graphics card, but I would always get the same igdkmd64.sys BSOD, which rendered my Windows installation useless. Also, I did not find any "Intel HD" devices in the device manager, even with "show hidden devices" turned on.

After 5 or so more installations, I noticed that the BSOD would occur 5-10 Minutes after boot regardless of what I would do, as long as I didn't do nothing. I couldn't even run Windows Update for the same reason (I unchecked the Intel HD drivers update).

The frustrating thing for me is, that even if I do not have a igdkmd64.sys driver installed (I checked) it still crashes with this file given as as reason. I some installations, I actually found that file and tried deleting/renaming/moving it, but it would always reappear after a reboot.

Edit: I installed Windows 8.1 64 bit from a USB flash drive created with the BootCamp Assistant, which also downloaded the support software. I also tried installing Windows 8, but this resulted in it blackscreening after ~20s and restarting in the setup (where you are asked to enter your username and such).

  • Are you installing using BIOS/MBR or EFI/GPT? From where did you get the "Boot Camp Support Software" that you are using? Are you doing a 32 or 64 bit install? You should be able to install windows. You say you did boot Windows 8.1. This this the version of windows you what to run? What others versions have you tried? Update your question with answers to my questions. Also, are you using a DVD, flash drive or other method. I have installed Vista, Windows 7, 8, 8.1 and 10 on my mid 2007 iMac. Also, Windows 7 and 10 on a 2011 iMac. I am sure we can find a way to install on your MBP. – David Anderson Feb 7 '16 at 20:08
  • Did you edit the Info.plist file to either allow the creation of the USB installer or to enable an UEFI install? I am not asking to you to do this. It would be the wrong thing to do. I am asking if this is how you proceeded. – David Anderson Feb 8 '16 at 2:00
  • @DavidAnderson Yes I have, as the DVD version of Windows 8 would not let me install itself, the "this disk is not of GPT partition scheme" error would not go away using a DVD – Chester Feb 8 '16 at 16:45
1

It is hard to answer your questions. Mostly, because you have not fully answer my questions. I am going to guess that you are trying to install Windows to boot using the EFI firmware interface instead of the legacy BIOS interface. If so, you have not been the first to try. It is really not a question of whether or not you can get Windows to boot using the EFI, but rather what method the "Boot Camp Support Software" expects you to use.

I did an experiment last night. I have a mid 2011 iMac. The "Boot Camp Support Software" for 64 bit Windows 7 is version 5.1.5621. Your Mac would use the same software. My internet connection is 40 Mbps so downloading was not a problem. I also used the Boot Camp Assistant running under OS X 10.11 to download the software to a flash drive. I then compared every single file using windiff.exe. The files are identical. This is not proof that version 5.1.5621 do not contain any EFI drivers, but I do not think the drivers have not changed since the release of Windows 7. When Windows 7 was released, no Macs were booting Windows using the EFI.

OS X does not boot using the EFI specification. To use the specification, OS X would have to store software in the FAT formatted EFI partition. It does not. OS X does not even require a EFI partition to boot. The firmware is capable to reading HFS formatted partitions and recognizing the OS X operating system. Many Linux operating system take advantage of this. Fedora, for example, appears to the Mac firmware to be OS X. Once loaded, it transfers control to grub to finish the booting process.

In the end, I think you are trying to do something that can not be done. If your MBP was a year newer, the story would probably be different.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .