As part of the installation a PHP 5.4 cartridge from openshift.com on my Mac with OS X 10.10.5 in the Terminal I noticed a message about it loading OpenSSL 0.9.8 for compatibilty with PHP.

Later, trying to install getcomposer.org it is giving me a warning:

Some settings on your machine may cause stability issues with Composer.
If you encounter issues, try to change the following:

The OpenSSL library (0.9.8zc) used by PHP does not support TLSv1.2 or TLSv1.1. If possible you should upgrade OpenSSL to version 1.0.1 or above.

openssl version command in terminal reported OpenSSL 0.9.8zg 14 July 2015

Should I update to OpenSSL version 1.0.1?


2 Answers 2


OpenSSL 0.9.8zc or 0.9.8zg does not support TLSv1.1/1.2 which can cause vulnerabilities while downloading using HTTPS links.

You should update OpenSSL to latest version from official site.


I am using a MAC OS X 10.10.5. You need to update OpenSSL doing:

  1. Check the current version

    openSSl version
  2. The ports tree has been updated

    sudo port selfupdate
  3. Now, you can update your openSSL

    sudo port upgrade openssl
  4. Check the new version

    openSSl version

If the error is still present:

  1. You need to check the PHP version

    php --version
  2. Change it to your newest PHP version

    vi ~/.bash_profile
       export PATH=/Applications/XAMPP/bin:$PATH
    source ~/.bash_profile
  3. Check the new version

    php --version
  • Shouldn't you also explain how to install port ?
    – nohillside
    Commented Apr 28, 2020 at 6:27

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .