0

I've got a 2012 Retina MBP running 10.11.3. In the past I've used a Linksys USB3GIGv1 ethernet adapter to connect to a wired network, however for the past week or so it hasn't worked.

When I plug the adapter into the USB port with System Preferences > Network open, nothing gets updated; the interface doesn't show up in the list on the left side of the window, and if I turn Wi-Fi off, I lose my connection to the internet. The light on the adapter does flash at random, though, as it used to.

I tried disabling and re-enabling all the interfaces through ifconfig <iface name> off/on, but no luck there. I've also tried using an unbranded ethernet adapter which had previously worked, as well as switching out the cables for one with a known working connection, and even hooking the dongle up to a Thunderbolt display, but all to no avail.

The dongle does show up in System Information > USB and the brand and model are correctly identified on the USB 3.0 bus.

Finally, I've tried manually installing the drivers from Linksys's website, but they only support OS X up to 10.9 (I had used this dongle post-10.11, and it stopped working almost randomly).

How can I get my MacBook to connect to the internet using an ethernet adapter considering all of that?

1

The old driver probably doesn't work with El Capitan. As indicated on the Linksys website Belkin is working on creating a Linksys driver package for the OS X 10.11.

Meanwhile you may try the RealTek beta driver here.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .