2

Problem

I have a Time Machine backup which contains a lot of valuable information and I'm trying to access it. What's the problem? I'm trying to mount it and nothing1 happens.

  1. Nothing happens? So I tried to eject the network disk containing the sparsebundle and I got an error saying:

"The disk backups couldn't be ejected because finder it using it"

What??? My guess is DiskImageMounter is mounting but is ridiculously slow?

Notes / Updates

Note: installd is eating up my CPU usage, is this in anyway related to DiskImageMounter

Note 2: If I go to "Browse Other Backup Disks" it finds the sparsebundle but none of the backups show.

Update: Seems like mds is going crazy on the backup drive. I'll try to disable spotlight and see what I can do


There must surely be a better way to browse a Time Machine backup on a network disk

If not, how can my problem be fixed?

  • If you reboot your system does the issue persist? For installd see What is installd, and why is it eating my CPU? – user3439894 Feb 5 '16 at 4:50
  • @user3439894 yup of course. I know about installd but I just added it if it has anything to do with mounting the disk image – Downgoat Feb 5 '16 at 4:51
  • You didn't answer my question! So I'll ask it again. If you reboot your system does the issue persist? As far as installd have you looked at Open Files and Ports for it in Activity Monitor to see if it shows anything pointing to the Time Machine sparse bundle? – user3439894 Feb 5 '16 at 5:02
  • @user3439894 yes I think fsck_hfs looks like it's something to do with mounting. It does persist if I restart. I'm not seeing an Open Files and Ports tab... – Downgoat Feb 5 '16 at 5:09
  • actually now I'm seeing a diskimages-helper which is accessing the disk images... It's been over 30 minutes and no mount so I'll see if anything happens – Downgoat Feb 5 '16 at 5:10
0

It's not Time Machine, or anything

It's Spotlight. How?

Spotlight

Spotlight indexes everything. Even on an external disk. My backup .sparsebundle was > 2 TB. My computer can't handle this. Spotlight would index everything before it showed in finder.

Debugging

First, to see what was using the disk. Run:

sudo lsof | grep /Volumes/<Volume Name>

I got something like:

diskimage 519           vihan    4r      mds

and about 4 of those. That meant Spotlight was going haywire.

Disabling

Disabling spotlight is simple. RUN THIS BEFORE TOUCHING THE .SPARSEBUNDLE

sudo launchctl unload -w /System/Library/LaunchDaemons/com.apple.metadata.mds.plist

That should disable Spotlight. Now you can double click the .sparsebundle and continue as from this answer

  • Newer versions of MacOS won't allow this - you'll see 'Operation not permitted while System Integrity Protection is engaged' instead. This article describes the workaround, which I haven't tried just yet, but I'm instead trying to disable my Time Machine drive from indexing (in System Prefs -> Spotlight -> Privacy)... and if that doesn't work I'm trying to copy the sparsebundle locally (although I suspect I won't have enough disk space for that!) – Tim Malone May 12 '18 at 3:44
  • You can omit "-w" option so SIP will not complain. – mkll Sep 11 '18 at 16:53

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .