1

Upgraded to El Capital 10.11.3 yesterday, at the last prompt where it asks to login using iCloud I supplied my user/pass and then it sent code to my iPhone which I typed correctly but after that it just froze there and continue button never enabled

So at this point I had to do hard reset to get access back

after that since my first login

Issue
a. When trying to use System Preferences > iCloud > login with my id
I get an error saying "keychain login cannot be found to store "
b. Just tried to add a Wi-Fi password and got error saying "Keychain System cannot be found to store"--- so it seems keychain in general is broken or impacted
c. I use Internet Accounts > Google Accounts for Contacts > every now and then i get notification on top right saying Google Password Required, no matter how many time I enter it keeps saying that message

What i have tried so far
1. went to ~/Library/ and then moved Keychains folder to my desktop, Rebooted so it would recreate the keychain again but this didn't
2. earlier I had Two Step authentication enabled on my iCloud id so i disabled it

The very same iCloud account works fine on other OS X and iOS so I am sure my account is okay

  • keychain/iCloud/Messages/FaceTime all seem intertwined - have a look at apple.stackexchange.com/questions/105221/… including the 'recommended but unsuccessful'. It seems everyone finds a slightly different fix to this one. – Tetsujin Feb 5 '16 at 9:50
  • Am having the same problem. Please keep updating these posts, as this is hugely annoying, especially since first aid is missing now. Also I could use some more dummy-proof step by step instructions for "copying keychain", "removing it from Keychain Access", and "adding it back". Not a total novice but never have dealt with any of these things. have 10.11.3, and an additional problem I have is that my login keychain is listed as (read only) and is locked; the icon to the left of the login keychain is an empty square box. – user169306 Feb 7 '16 at 15:29
  • For me so far removing adding repairing and even recreating did to fix it I am waiting on Apple support and will update if a solution is found – SeanClt Feb 7 '16 at 18:02
  • No update from Apple yet. Very disappointed, I have stopped using iCloud and other Internet Accounts. becoz couldn't tolerate those annoying popups. Here's a secondary issue i am having because of this issue apple.stackexchange.com/questions/227680/… – SeanClt Feb 16 '16 at 2:29
1

not sure if this means anything but i deleted all system keychains and restarted. I had to re-enter passwords for wireless and re-get certs for company wireless but it worked. Keychains are the bain of my existance some times.

  • Issue is really because of some bad apps conflicts so removing non Apple apps that you don't need might be a good start – SeanClt Jun 21 '16 at 1:24
  • Ugh, yeah, the Keychain system is so incredibly fragile. It blows up on me periodically for reasons I can never determine. – Brian Knoblauch Jul 27 '16 at 12:36
0

Had the same problem with my Mac, and I can't say what exactly solved it. I copied my keychain, removed it from Keychain Access, rebooted, and then added it back, and that seemed to fix it, but I can't say why since supposedly removing it from Keychain Access then adding it back should be enough. If that doesn't work, there are versions of Keychain Access from earlier versions of 10.11 available that have Keychain First Aid that may solve your issue: however, it didn't for me.

  • Thanks for sharing I was on meeting with Apple this morning and we tried that still having issues it's really annoying I have disabled iCloud and rest seems to be working for now not able to use FaceTime – SeanClt Feb 5 '16 at 3:28
0

TeamViewer & Junos Pulse were the culprit in my case

Removing TeamViewer and rebooting fixed my issue then i had to remove JunOS Pulse as well, because as soon as pulse started it broke again

This discussion helped https://discussions.apple.com/thread/7276820?start=30&tstart=0

Go to 3rd page and following passage

Example Apps: MagicPrefs Hazel AppleRemote Desktop (Remote mode) Bomgar (Remote Support Mode) TeamViewer (Remote Control Mode)

The above apps are culprit and broke my keychain

Recommendations if you are having the same issue then i would recommend start removing non-apple apps to find the one causing the issue in your environment

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .