9

What's wrong: I hit CMD+SPACE to open up spotlight, typically type in the name of the application I want to start, hit enter and either the wrong app or no app at all will start, because the app name is missing the first character. "Learn to type" I hear you say but wait: as I enter the first character in the search bar, the cursor jumps to the beginning of the line and my second character input overrides the first one. So entering for example "ever", in order to start Evernote, will result in "ver". "php" to start PHPStorm will result in "hp" and start my damn HP printer app and so on.

This cursor jump to the beginning of the line will not happen in any other application and even if I accept the fact that my cursor jumps from time to time, I don't get why the second character overrides the first one. I'm not even sure if you can configure your Mac to always override the character at current position, but I surely haven't.

So this keeps on happening quite regularly and I cannot reproduce it. It just happens and when I try it again (close Spotlight, CMD+SHIFT again), it won't happen again, even if I give it like 5 tries or so.

It won't kill me but I am a software developer myself and this kind of bugs just leave me frustrated plus I can not imagine that this is the desired behavior. I have seen some talk about this issue on the internet but I did not come across a solution..

I have 3 MacBooks, different ages, all with German keyboard layouts and German set as system language and they all do this. Just mentioning this, because after that fact, I can barely imagine this isn't affecting at least a lot, if not all, MacBook (Pro?) users.

  • 13" Pro 2010 or so
  • 15" Pro Retina 2013
  • 13" Pro Retina 2015

They all run El Capitan but I already encountered this before. I don't know the OS X version I had installed when I first stumbled across it.

  • 2
    I can reproduce this consistently. Some sources say that Karabiner and/or Seil may be at fault, but disabling them doesn't fix the problem. To reproduce, try ⌘+space and type "finde" (with out the r), hit enter, then ⌘+space again and type anything at all. It eats the first character. – Stefano Palazzo Feb 4 '16 at 18:58
  • @StefanoPalazzo Tested and confirmed, submitting a bug report to Apple. – JMY1000 Feb 5 '16 at 3:29
5

here is a solution which have worked for me https://www.reddit.com/r/OSXElCapitan/comments/3wczrk/spotlight_eating_the_first_letter/?

iamtaybo sugested to UNCHECK "Allow Spotlight Suggestions in Spotlight" in System Preferences->Spotlight

  • Sucks that you have to do that though. Hopefully this get patched. – JMY1000 Feb 10 '16 at 18:00
  • 1
    Didn't work for me. OS X 10.11.4. – silvansky Apr 28 '16 at 15:37
1

Confirmed bug, submitted bug report.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .