1

I'm currently trying to create a build of our app for TestFlight but for some reason Apple is not adding the beta-reports-active to the .mobileprovision file anymore (I checked the source of the file, it's just not there).

Application Loader keeps complaining that I don't have any Beta Entitlements (the appName.entitlements does contain this key) and when I regenerate the provisioning files at developer.apple.com I just get the same certificate without the beta-reports-active in it.

How do I get a proper Ad-Hoc certificate again so I can upload a new version to TestFlight? (I lost the previous private keys in a major crash which deleted all my data from my Macbook and those private keys weren't in my backup thus the previous profiles are unusable now)

  • What specifically were the private keys you lost? If they are for the developer signing certificates, you could revoke those and request new ones in the developer portal. I'm assuming you are following developer.apple.com/library/ios/qa/qa1830/_index.html - if not, please edit your renewal steps into the post... – bmike Feb 4 '16 at 15:30
  • I haven't revoked the old certificates yet, I just created two new certificates (one for development and one for distribution) and used those to re-generate the Ad-Hoc certificate. – MegaMiley Feb 4 '16 at 15:41
  • I just revoked all old certificates and regenerated them in Apple's Developer Portal but only the production certificate contains the beta-reports-active key, the AdHoc still doesn't. – MegaMiley Feb 5 '16 at 12:09
  • I wonder if this change is undocumented (for the recent moments) and intentional and others will chime in with the same observation over time as they renew certs... – bmike Feb 5 '16 at 14:03
1

For anyone coming to this point at a later stage, we contacted Apple about this and most likely there was an undocumented change that removed the Beta Entitlements key from AdHoc certificates, you now have to use the Distribution certificate in order to upload a TestFlight build (which worked for us).

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .