2

When I select text in iTerm2, the text it copies cuts off at after a certain (seemingly arbitrary) point. I did a few tests and its usually between 800 and 1500 bytes of input.

Why is this, and how can I change the settings in iTerm2 to allow me to copy all the text I highlight?

Note: I don't have this problem in the default "terminal" application, just in iterm.

1

It should copy all text you have selected. You should check under Preferences>Profiles in the Terminal tab how big your scrollback buffer is. However it is specified in lines not bytes.

  • Good idea, but the scrollback buffer for my active profile is already set at 1000 lines. – turtlemonvh Feb 3 '16 at 18:53
1

To update buffer size of copied text, I followed below steps and worked fine.

  1. Quit iterm2.
  2. Open mac terminal
  3. Execute below commands

    defaults write com.googlecode.iterm2 QuickPasteBytesPerCall -int 1024
    defaults write com.googlecode.iterm2 QuickPasteDelayBetweenCalls -float 0.01
    

change 1024 (in bytes) and 0.01 (delay) according to your needs.

Found from here

0

Try to turn off Applications in terminal may access clipboard in the settings. I found this information as i was researching the problem myself. This seems to be still relevant, although this question is already quiet old.

To quote the information on the site (Source):

This works through ANSI escape sequences, and you actually want this OFF. Before today I had this setting on, which kinda worked but it always truncated the clipboard, which made it completely frustrating for copy-pasting larger things such as logfiles.

enter image description here

  • When I uncheck that option then nothing gets pasted at all. Have tried this repeatedly. – javadba Mar 10 at 5:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .