1

I have a 2 TB Fusion Drive in a 5K iMac (Late 2015). Two days ago, I started the bootcamp assistant to create a partition for Windows 10. It got stuck (let it run 30 minutes), however, which forced me to reboot the machine. After booting, I lost 164 GB from my Fusion Drive.

I googled and found a solution, which states to boot into recovery and run diskutil cs resizeStack <LGVID> 0g, which I did. However, I am not able to let it resize, because it immediately throws an error. Following the error does not work either.

I also tried repairing the disk with Disk Utility which runs for a few minutes, then says everything's fine. Nothing changed of course.

diskutil outputs

Output of gpt -r show /dev/disk0: enter image description here

Output of diskutil verifyDisk disk0: enter image description here

What can I do now?

  • Please add your system version. To verify a Fusion drive use diskutil verifyDisk diskX with X=disk identifier of the two disk building the drive - in your case either 0 or 1 (check the physical volumes in your screenshot). – klanomath Feb 3 '16 at 11:32
  • OS X El Capitan 10.11.2 (haven't upgraded to .3 just yet). If I run it with disk0 or disk1, it complains that it will delete my stuff. – bluefirex Feb 3 '16 at 11:33
  • Using the verifyDisk (instead of repairDisk!) argument deletes stuff? The proper command to resize a stack in El Capitan is a distinctive size (i.e. diskutil cs resizeStack 25FF.... 2126g or slightly smaller like 2125500m) – klanomath Feb 3 '16 at 11:37
  • Please also add a screenshot of gpt -r show /dev/disk0 – klanomath Feb 3 '16 at 11:40
  • Sorry, misread that as repairDisk. Just appended two screenshots with the outputs. – bluefirex Feb 3 '16 at 12:17
1

Since I wasn't able to resize the stack and seemingly no one was able to help me, I decided to to this:

  • Make an image of the Fusion Drive Volume and save it onto an external hard drive
  • Delete the Fusion Drive
  • Rebuild the Fusion Drive
  • Install OS X to let it create the Recovery partition
  • Boot OS X, run Bootcamp Assistant
  • Run the Windows Installer WITH NO EXTERNAL DRIVES ATTACHED (!)
  • Restore the image to the Fusion Drive
  • Be happy after 10 hours of work

Not the best procedure to do but as this was the only thing that seemed to help, I did it.

For recreating the Fusion Drive I used this answer from klanomath: https://apple.stackexchange.com/a/168744/109455

I have a working setup with OS X El Capitan and Windows 10 now.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .