0

I got an external camera attachment for iPhone and it has an external power input. My understanding is that the camera is a part of an MFi (made for iPhone) - a certified accessory.

According to the manufacturer, it is supposed to charge phone when the camera receives external power:

  1. I plug in the camera, the charging symbol appears
  2. The camera pops up a dialog asking to interact with a default program
  3. Charging symbol disappears and does not come back
  4. I can confirm that the phone does not receive power - it discharges when the camera is attached.

I called the manufacturer and the camera is not defective - it has something to do with new iOS- I tried 9.0 and 9.2

Is there something new about MFi (made for iPhone) program that prevents external devices from charging the phone? Is there a way to prevent the phone from creating an interaction dialog for that particular app?

enter image description here

I verified that the accessory is MFi compatible: enter image description here

1 Answer 1

1

Check to make sure there's not any lint buildup in the Lightning port. Get a wooden or plastic toothpick (do not use anything metallic) and clean the port out, swiping from one edge to the other, then pulling out any bunched up lint or dust. Even a small amount of buildup will prevent the accessory from fully seating properly, sometimes generating a "This accessory is not supported" error, or simply preventing the device from charging, even when it has worked properly before.

1
  • Thanks, the port was indeed dirty, however, the issue appears on two different iPhones. I have updated my question with more info
    – Alex Stone
    Feb 2, 2016 at 15:31

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .