3

I'm trying to add a configuration profile to my Apple TV via Apple Configurator 2, as documented, however when I add the profile I get this error:

An unexpected error has occurred with “Apple TV”.

You cannot install apps or other media on Apple TV.
[ConfigurationUtilityKit.error – 0x3E9 (1001)]

enter image description here

In fact, whenever I try to do any management of the Apple TV through Apple Configurator, it fails with the same message.

I've tried:

  • I've tried clearing the configuration files (at ~/Library/Containers/com.apple.configurator.*)
  • Updating and reinstalling Apple Configurator
  • Restarting computer
  • Full factory restore of Apple TV
  • Fresh OS X install (on external hard drive)

I'm able to sideload apps through Xcode through the same Mac, so that implies that the USB cable is fine.

1

I found something with similar issues on this thread:

https://forums.developer.apple.com/thread/21638

Process > Perform all Mac updates > reboot then open the apple configurator again > select store at the top > sign in with apple id.

While it applies to deploying Apps to iPads, the Apple TV runs iOS so the solution may be the same.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .