1

I'm on OS X 10.11.3, aka El Capitan.

I can't connect to mail servers running only TLS version 1.2 or 1.1 with Apple Mail.

IMAP as well as SMTP connections are always established using TLS 1.0.

Could that be correct?

If so, why doesn't Apple Mail support TLS 1.2 yet?

3
  • 1
    Because Apple system is outdated. Them along with Microsoft Exchange lower than 2013 don't support TLSv1.2.
    – user197648
    Aug 17 '16 at 21:28
  • 4
    I just did a wireshark on a connection on macOS Sierra and it negotiated TLSv1.2. Aug 17 '16 at 23:06
  • @AlanShutko that sounds promising, thanks for the information!
    – basbebe
    Aug 18 '16 at 5:10
1

This seems to be an issue with MacOS El Capitan and lower versions. Upgrades to Sierra and High Sierra resolve the issue.

However, there needs to be a solution for users on computers which cannot upgrade to Sierra and higher.

0

As much as I don't really want to move all of my mail to Thunderbird. I have found that it does work on El Capitan.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .