0

Recently my El Capitan has started asking me for my Apple ID credentials, out of the blue. It often happens after waking the system from sleep, but not always, and sometimes it happens during the middle of my work. So I guess some kind of timeout or some such is involved as well.

I don't want to get into the habit of entering my password without knowing what for. And I don't have my user account officially associated with my Apple ID, since I like to keep separate things separate. On the latest update I skipped the step asking me for my Apple ID, as I did when setting up the system. Not sure whether that's in any way relevant.

  • So what service exactly is asking for my ID? How can I find out?
  • Why is it asking for it? Is there any legitimate reason why it should do so?
  • Can I be sure that entering my password without knowing more won't be used to legitimize a paid purchase in some way?
  • How can I stop the system from pestering me with this? I want to enter my password only when installing (or updating) apps from the AppStore.
  • Am I the only one observing this, or is this a known issue?
  • At a guess, you skipped the AppleID at the point is was going to sign you in to iTunes, iCloud, iMessage & FaceTime… that's going to give you a lot of nag-screens. You might check that you are actually signed out of all the above, but idk how to prevent it from asking again. Apple really do want your machine associated with your ID, for continuity, handoff etc. – Tetsujin Feb 1 '16 at 10:12
  • I don't use any of these services. – MvG Feb 1 '16 at 10:41
  • See also if the OS is trying to update in the background. Updates are done through the App Store. – bjbk Feb 1 '16 at 14:33
  • @bjbk: That sounds very plausible. I don't know how to check whether the OS is attempting to upgrade just now. But I found that in the AppStore tab in the System Preferences I can have it save the password for free downloads. I'll see whether that does the trick for me. – MvG Feb 1 '16 at 14:40
  • 1
    That's a good start. I'll put together an answer based on the update possibly and post soon. – bjbk Feb 1 '16 at 14:42
1

Go to System Preferences and select App Store

There you can turn on/off automatic updates. Also, you can adjust the Password Settings here.

App Store Settings, System preferences

App Store Settings

  • Thanks! I've accepted this for now, and would unaccept it if this didn't fix the issue as I expect it will. The upvote stays, since this is a useful answer in any case. – MvG Feb 1 '16 at 14:58
  • I suspect this is your issue. But will be very interested to see if it is something else. Cheers! – bjbk Feb 1 '16 at 15:28
  • Alas, that's not it. Or at least not just this. I just got asked again, some five minutes after waking up the machine. ☹️ – MvG Feb 3 '16 at 8:57

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .