1

It does not on Windows, but on OS X, it wakes up the computer from sleep. If Android Studio is not running it does not wake up.

Steps to reproduce

  1. Connect an Android device (I used a Nexus 7 2013).
  2. Run Android Studio
  3. Click the Apple icon in the status bar, and then click "Sleep".

The computer wakes up automatically a few seconds later. The only walkaround is disconnecting the device or quitting Android Studio. Is there any better solution to this?

2
  • I've never used Android Studio but I suppose it sets up a network connection to your mac. Have you tried turning off Wake for network access in the Energy Saver settings from System preferences?
    – root
    Feb 1, 2016 at 7:42
  • I had disabled both waking from network and Bluetooth input devices. I guess the USB connection is the culprit. On Windows, there is something like "Allow this device to wake the computer", but OS X does not seem to have such feature. Feb 1, 2016 at 19:16

0

You must log in to answer this question.

Browse other questions tagged .