6

On my iPhone homescreen there's an app which in an half-downloaded(actually, more like barely downloaded) state -

Rage

(In case you're curious, I was trying to download Rage during it's on-sale-for-free-period)

Now, I can't get rid of it from my home screen. I can hide it in a folder, I can install the downloaded app next to this "Loading" shell having downloaded the app later in iTunes.

iTunes won't let me delete this item from my home screen - the "x" overlay for uninstalling an app is not coming up either.

So, how can I remove it?


bmike just helped me with some troubleshooting, but we weren't able to get this question fixed, yet. Here's the conversation between the two of us. Would appreciate any other answers.

  • If it's a WiFi only sized app, turning off WiFi will stop the download and might allow you to hit the X when you are in the move/delete mode. See apple.stackexchange.com/questions/5818/… for another workaround in that case. – bmike Aug 19 '11 at 17:24
  • possible duplicate of App stuck while downloading at stage of 2% – bmike Aug 19 '11 at 17:27
  • @bmike it's a WiFi sized app, but I don't have access to WiFi anywhere closeby. The tip you mentioned doesn't work because iTunes says it's already downloaded. – Sathyajith Bhat Aug 19 '11 at 17:28
  • @bmike can you move the comment to an answer so that I can accept it? In the end, I had to do that because nothing else would work. – Sathyajith Bhat Oct 7 '11 at 18:07
  • 1
    Once again, thanks for all your help @bmike. I've slightly edited your answer to reflect what I did. – Sathyajith Bhat Oct 7 '11 at 18:23
3

One way is to tap on the app icon once you're connected to a WiFi hotstop. This will start/resume the download. Once the app is being shown as "loading", just tap it again to remove from it's limbo state and move to paused state. This will allow you to hit the X when you are in the move/delete mode.

Sadly, a total restore and set up of your device as new will always work at the cost of your time to re-configure all of the sync settings. Unless each app has an export/import or cloud sync ability, you could lose progress or data from other apps, so it's a very broad hammer for a narrow problem.


Several other questions here might help, but none seem to be totally equivalent.

4

Reboot.

I had an app stuck in the Loading... state and a reboot of my iPhone cleared it away. I was able to re-download it again without any issues.

To reboot your phone hold down the Power button for 5 seconds. You'll see the power off slider appear. Slide it to turn the phone off. Once off, use the Power button to turn it back on.

  • Reboot didn't help, the app's already downloaded and installed on iTunes, this is what I get after syncing i.imgur.com/DpDjl.png – Sathyajith Bhat Aug 19 '11 at 17:52
  • +1 for rebooting, -1 for "hold down the Home and Power buttons at the same time for 5 seconds" since you just need to hold down the power button – glorifiedHacker Aug 19 '11 at 18:06
  • @glorifiedHacker fixed. Shows you how often I reboot my iPhone. – Ian C. Aug 19 '11 at 18:37
  • @Sathya have to tried deleting it now that it's been properly installed and rebooting? – Ian C. Aug 19 '11 at 19:02
  • @IanC. yes, tried deleting but the overlay for uninstall doesn't come up, so it's stuck there. – Sathyajith Bhat Aug 20 '11 at 3:43
2

This is an absolute nightmare when you get it. I can you tell you roughly what I did to get it resolved but YMMV.

  1. Download the app in iTunes
  2. Hook your iPhone up and tell the app to copy
  3. Unplug, switch on flight mode, reboot
  4. Now it's rebooted in flight mode it'll stop itunes from trying to download
  5. Sync your iPhone, it should copy it and override the OTA iTunes download

Note, I went through a week and a half of trying things so there might be pre-steps but those are the ones that led up to it being fixed.

  • This is the same as what @bmike mentioned in the chat discussion, but it doesn't help – Sathyajith Bhat Aug 20 '11 at 3:45
  • This answer actually worked for me. Download the app in iTunes and try to install it in your phone! – Henrique da Costa Aug 18 '16 at 13:14
1

On my iPad 2 I had a partially loaded app I could not delete using the press-&-hold-until-shakes-then-tap-the-X method. "Ghost App." Very annoying. I did this, and it worked. But, I knew the name of the ghost app

  1. Reboot
  2. Press and hold, then move the ghost app on top of another, creating a folder with the ghost and a regular app in it. I renamed the folder "Deleted Ghosts"
  3. Press the (physical) button turning off the shakes
  4. Press & hold to get shakes, and drag the regular app OUT of the folder, leaving a folder with only the ghost app in it.
  5. Press the (physical) button turning off the shakes
  6. Open apps store and download the app is the ghost app
  7. This made the ghost app - and its folder - disappear.

Good luck.

0

I just had the same issue. I just went to the App Store, found it again and hit the cloud to download again and it worked.

0

The following trick has helped me in the past:

  1. Open the Appstore app
  2. Press one of the tab bar icons, e.g. 'Updates', 10 times in a row
  3. The screen should flash (if it does not, repeat step 2 until it does !)

I know it sounds weird but it seems to help for some of these cases (it did for me !)

It is not something I discovered myself. There are several mentions of it on the web.

One of them is: force-refresh-the-ios-app-store-by-tapping-the-tab-bar-1750465871

Searching for "appstore press 10 times" shows more of them.

  • This cleared up the app store update progress but still can't remove the app or complete the update. – darkstar3d Nov 19 '16 at 18:09
-1

I got the same problem with my phone. I Turned off my mobile and turned on it again. Half downloaded app is disappeared. Hope this helps you.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .