2

I've noticed that typying -- in text edit results in those signs being converted to en dash: . This is highly undesirable behaviour. For example correct formatting for the SRT files is (related problem):

time --> time

automatic en dash insertion is unnecessary here. Hence my question, how to disable it in TextEdit (the problem does not occur in Atom or TextWrangler)?

2

Open TextEdit Preferences (⌘,) and uncheck Smart dashes.

You will need to close and re-open your documents for the change to take effect.

|improve this answer|||||

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .