2

Using OS X 10.11.3 (15D21), with macports, apache 2.4/php 7.0.2 with OS X Server installed (for TimeCapsule sharing)

I can't seem to prevent the inbuild apache from starting on reboot.

if i use:

sudo launchctl unload -w /System/Library/LaunchDaemons/org.apache.httpd.plist

then reboot and use the command

imac:scripts pete$ ps -Al | grep httpd
    0   245     1        4   0  31  0  2623184  21960 -      Ss                 0 ??         0:00.36 /opt/local/apache2/bin/httpd -k start
   70   280   245      104   0  31  0  2623184   1020 -      S                   0 ??         0:00.00 /opt/local/apache2/bin/httpd -k start
   70   281   245      104   0  31  0  2623184   1052 -      S                   0 ??         0:00.00 /opt/local/apache2/bin/httpd -k start
   70   282   245      104   0  31  0  2623184   1044 -      S                   0 ??         0:00.00 /opt/local/apache2/bin/httpd -k start
   70   283   245      104   0  31  0  2623184   1100 -      S                   0 ??         0:00.00 /opt/local/apache2/bin/httpd -k start
   70   284   245      104   0  31  0  2623184   1088 -      S                   0 ??         0:00.00 /opt/local/apache2/bin/httpd -k start
    0   510     1     4004   0  31  0  2496992   9540 -      Ss                  0 ??         0:00.12 /usr/sbin/httpd -D FOREGROUND -f /Library/Server/Web/Config/apache2/services/ACSServer.conf -E /var/log/apache2/services/ACSServer_error_log
   70   522   510      104   0  31  0  2494944   1184 -      S                   0 ??         0:00.00 /usr/sbin/httpd -D FOREGROUND -f /Library/Server/Web/Config/apache2/services/ACSServer.conf -E /var/log/apache2/services/ACSServer_error_log

the server app websites is turned off, and if I uninstall the server app, the problem resolves - it is just I want the server app to use TimeCapsule backups.

4

I had the same problem!

You have to edit:

/Library/Server/Web/Config/Proxy/apache_serviceproxy.conf

and

/Library/Server/Web/Config/apache2/services/ACSServer.conf

Change "Listen ..." to "# Listen ..." (Change to comment).
This prevents the httpd from starting.

You have to restart after this!

  • You have to restart after this! – Franz Podek Jan 28 '16 at 18:59
  • You can skip the restart if you do a: sudo killall httpd Also, I took a look in the ACSServer.conf file and I didn't see any mention of port 80 or 443 in it – tegbains Jul 13 '16 at 22:56
  • 2
    Also didn't find any "listen" in /Library/Server/Web/Config/apache2/services/ACSServer.conf. I just commented out listening on port 80 and 443 in /Library/Server/Web/Config/Proxy/apache_serviceproxy.conf, then ran sudo killall httpd to kill those processes and it worked fine. – Nick M Jul 26 '16 at 4:18

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .