0

I cannot connect to the Internet on My Mid 2013 MBA, running 10.11.3 either through Wi-Fi connected to my router, or tethered to my iPhone via USB or Bluetooth . Rebooting the machine has not solved anything.

I cannot ping any external IP, I can ping other devices on the network.

All other devices in the house (Various ipads, iphones, windows PC's, NAS Box, Raspberry Pi's etc) all connect fine through the same router. Resetting the router hasn't helped either.

  • 1
    Does it connect to WiFi, but gets no internet access? Do other devices get tethered internet from your iPhone successfully ? – latusaki Jan 28 '16 at 0:02
  • Correct. I can connect to the routers admin panel. – MrBliz Jan 28 '16 at 0:04
  • 1
    Try disconnecting some of the devices that are using the router, I am not sure what happens once you reach the client limit for your router. – latusaki Jan 28 '16 at 0:09
  • 1
    Ah... if other devices can access the internet through your phone then it shouldn't be a problem with the router.. hmm... – latusaki Jan 28 '16 at 0:10
  • 1
    Try approaches from here: apple.stackexchange.com/questions/177873/… good luck – latusaki Jan 28 '16 at 0:25
1

I've had similar problems with macbooks. I've found that going into "Network Preferences" / "Location" / "Edit Location" and creating a new location can work.

Here's another option: set your IP manually to an IP the router will accept, instead of by DHCP. If your other devices connect at 192.168.1.25, for example, configure yours to 192.168.26 (keep it close to other IPs in case your router is set to limit to specific IPs). Apply your changes and try connecting.

  • Thanks, the problem is solved now, but useful to know in future. – MrBliz Jan 28 '16 at 11:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .