0

The SSD in my Macbook Pro died suddenly. I bought a blank one, installed it as the internal drive, and booted into recovery mode by holding Command + R.

After letting it connect to WiFi and download its tools, I tried installing OSX on the new hard drive. However, when it said "select the disk where you want to install OS X", the drive was not listed.

So I went into Disk Utility and tried to format the disk. Anytime I tried to partition or format it (and I tried many different options), it gave me an error like "File system formatter failed". It would successfully create partitions, but that's it. I could not make the drive mountable.

How can I get it to format this drive so I can install the operating system on it?

2

Use Disk Utility from a working machine

I don't know why this didn't work in recovery mode, but a friend suggested I plug the SSD into a working Mac with a USB adapter and try using the working Mac's Disk Utility to format the drive.

I did, and that worked. Now I'm installing OS X on it using recovery mode.

Maybe (I'm speculating) the version of Disk Utility that I have recovery mode (my computer came with Mountain Lion) doesn't know how to work with SSDs?

In any case, Disk Utility on a machine running El Capitan was able to format the drive via my USB adapter.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .