0

Today I was trying to set up Windows on my MacBook Pro (15", Late 2011) over BootCamp.

I used the modified Info.plist-trick to create a bootable Windows 8 USB-drive and create a Bootcamp partition. After this was done, I tried to install Windows, but I ran into the problem of Windows not accepting the pre-made partition, so I deleted it and rebooted once again into the Windows installer to install it.

Everything went fine, but in the last bit of the installation process, it aborted - telling me that it couldn't change my boot configuration.

After this, it froze, so I held the power button down until it restarted. I couldn't boot from the newly created (hard drive) "EFI boot" section, so I booted the Recovery and tried to delete the two new partitions (the windows and the "Microsoft reserved" one). But it wouldn't let me delete the ~130MB partition named disk0s4. Even from Internet recovery, I couldn't get rid of it.

Next thing I did was try to run the Windows installer again, but from this point on, the installer would crash in a BSOD, almost instantly restarting my PC shortly after. I thought it had to be the disk0s4-partition that is causing all of this, so I made another effort deleting it - and I made it using the disk utility on my OS X. Having only one partition left, I tried rebooting, only to see that the "EFI boot" was still there. (note: this is not by USB-Drive, it has a hard-drive icon whereas the USB drive has a USB one)

I don't really know what to do from here to fix all this. I have no idea where this "EFI boot" is coming from (there is only one partition and a lot of unallocated space on my HD) and why my Windows installer is crashing.

I hope somebody can help me despite my long (but detailed) question.

Edit: fdisk output:

Disk: /dev/disk0    geometry: 60801/255/63 [976773168 sectors]
Signature: 0xAA55
         Starting       Ending
 #: id  cyl  hd sec -  cyl  hd sec [     start -       size]
------------------------------------------------------------------------
 1: EE 1023 254  63 - 1023 254  63 [         1 -  976773167] <Unknown ID>
 2: 00    0   0   0 -    0   0   0 [         0 -          0] unused      
 3: 00    0   0   0 -    0   0   0 [         0 -          0] unused      
 4: 00    0   0   0 -    0   0   0 [         0 -          0] unused      

gpt output:

      start       size  index  contents
          0          1         PMBR
          1          1         Pri GPT header
          2         32         Pri GPT table
         34          6         
         40     409600      1  GPT part - C12A7328-F81F-11D2-BA4B-00A0C93EC93B
     409640  486812704      2  GPT part - 48465300-0000-11AA-AA11-00306543ECAC
  487222344    1269536      3  GPT part - 426F6F74-0000-11AA-AA11-00306543ECAC
  488491880  488281255         
  976773135         32         Sec GPT table
  976773167          1         Sec GPT header

diskutil output:

/dev/disk0
   #:                       TYPE NAME                    SIZE       IDENTIFIER
   0:      GUID_partition_scheme                        *500.1 GB   disk0
   1:                        EFI EFI                     209.7 MB   disk0s1
   2:                  Apple_HFS Macintosh HD            249.2 GB   disk0s2
   3:                 Apple_Boot Recovery HD             650.0 MB   disk0s3

Seems like there is a hidden partition...

  • I assume you can still boot to OS X. If so, open a Terminal window and enter the following commands: sudo fdisk /dev/disk0, sudo gpt -r show /dev/disk0 and diskutil list. Edit your question and post the results. The commands will ask for your login password, this is normal. None of these commands will change your computer in any way. – David Anderson Jan 26 '16 at 22:01
  • Is there a reason you did not what to install using a DVD? – David Anderson Jan 26 '16 at 22:07
  • Yes, my MacBook didn't recognize my Install Disc (You just inserted an empty disc, what do you want to do?), so I went with a USB drive – Chester Jan 26 '16 at 22:14
  • @DavidAnderson I also didn't have any more discs to burn a Windows img to – Chester Jan 26 '16 at 22:27
1

Chasing Ghosts

You have successfully removed all windows partitions from your disk, but you have not yet removed all files added during your attempt to install windows. What is left are files in your EFI partition. The ghost is being caused by the file efi/boot/bootx64.efi stored in the EFI partition.

  1. Open a Terminal window and enter the following command.

    diskutil mount /dev/disk0s1
    
  2. From a Finder window, open the EFI disk. Next open the EFI folder. Remove the Boot and Microsoft folders.
  3. When finished, enter the command below.

    diskutil unmount /dev/disk0s1
    

Choosing an Installation Method

Generally the "modified Info.plist-trick" is just that. It is a trick. As far as I know, you can put the Windows installation files on the USB flash drive, but can not boot from this drive to install Windows. Generally, only the 2012 and newer models can boot the Windows installer from a USB port. If you succeeded, then your model must be the exception.

If you have an internal working optical drive, then this the preferred method to install Windows. If you need to buy a DVD, you are better off with a RW DVD. It will take longer to burn, but it is reusable. It is not sufficient to just burn the iso file to a DVD. You must burn the image stored in the iso file to the DVD.

There are two methods for installing operation systems on Macs. The first is the legacy BIOS/MBR method and the second is the EFI/GPT method. It is my understanding that the 2011 models are suppose to install Windows using the legacy BIOS/MBR method. From your post, I assume you were trying the EFI/GPT method.

You can choose which partition or media to boot from by holding down the alt/option key at startup. If a Windows installation DVD is in the Macs optical drive, you will get a DVD icon labeled "Windows". You can select this to install Windows using the BIOS/MBR method. There also may be a DVD icon labeled something like "EFI". You probably do not want to select this icon, since this will install using the EFI/GPT method.

A word of caution. If you using the BIOS/MBR method for Windows, you can not use any Windows software to change the disk partitioning. This must only be done from OS X. However, you can use Windows to format a partition.

  • Thank you! I'll try that once I get back home. I didn't know there was more than one method for installing Windows. My Mac is running EFI afaik (I can only boot from EFI USB drives). Either way, I'll retry it using a DVD after following your steps. – Chester Jan 27 '16 at 8:02
  • Seems like the "Ghost" has been "busted"! But I'm still bluescreening when trying to boot from my stick (worked before all this). Welp, I'll have to buy a RW DVD then (if that's what is ment by BIOS/MBR) – Chester Jan 27 '16 at 16:42
  • @Chester: I updated my answer. – David Anderson Jan 28 '16 at 1:17

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .