11

Up until recently I have had no issue with the Dock. I always leave it showing and don't have auto-hide enabled. Now whenever I switch program from Chrome to Skype or Terminal to System Preferences the Dock hides, even though I have never changed the setting to turn it on.

So far I've tried to fix this by right-clicking on the Dock separator and click Turn Hiding Off but it just changes back to Turn Hiding On once I switch programs. I've also gone into System Preferences and selected "Automatically hide and show the Dock". I've also killed the dock to restart it which was suggested here.

I think I've run out of options to fix this. I'm not even sure why or how it started.

2
  • 6
    Do you by accident use Command+Option+D for any purpose? It's the standard Finder's shortcut to turn the auto-hiding on or off.
    – EDP
    Jan 26, 2016 at 14:42
  • 1
    Not that I know of, I only use shortcuts for chrome. The thing I don't get is that it just keeps switching the value as soon as I change program Jan 26, 2016 at 14:43

3 Answers 3

13

As EDP pointed out Command+Option+D does this. The Spectacle app has shortcuts near this (+F for example) and I'll tap 'D' accidentally from time to time. Even if you're not tapping the shortcut inadvertently, Command+Option+D is a great way to switch the setting back when it's goes wrong.

If you want to prevent it, you can go to [Settings > Keyboard > Shortcuts], and disable the shortcut under Launchpad > Turn Dock Hiding On/Off.

Cool trick: open [Settings > Dock], and tap [Command+Option+D] a couple times.

2

I found that one of my Spaces kept causing the Dock to auto hide, and prevented things like the app switcher and swiping between spaces to stop working. Other spaces did not cause the same thing to happen. By closing the offending Space, the problem went away.

0

It likely has something to do with a window incorrectly behaving as if it is full screen (which auto-hides the Dock). I just had this issue with Chrome and I resolved it by taking Chrome full screen and back out again.

Hope that helps!

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .