1

The problem:

I'm connected to eduroam on an iMac, but only via ethernet. After restart/sleep/lock it automatically switches my 802.1x profile to the Wifi instead of the Wired. I have to manually switch it over every time.

Is there a way to reorder the profiles so Wired is the default? Or remove the wireless profile from the wired list? There seems to be no way to do this via the GUI interface.

OS: 10.10.5 Yosemite

Network preferences window, my issue

1

Found a solution by removing the WiFi profile from the Wired config file.

Location: /Library/Preferences/SystemConfiguration/

For me the file was: com.apple.network.eapolclient.configuration

Basically it's an XML file that has, for me, the two profiles for the wired connection (this would also work if you're trying to edit the wifi, as that's in the com.apple.airport.preferences.plist). The name of the profile is at the bottom of the data set, so Wifi was the 2nd one for me. I used <!-- Put your code inside these --> to comment the lower part out and the list now only contains the Wired profile.

The section looks like this when you're done:

<!-- <key>NUMBERS-LETTERS-ETC-ETC</key> 
    <dict>
        <key>AuthenticationProperties</key>
        <dict> ... lots of stuff ...
              <string>Wi-Fi (eduroam)</string>
               ... more stuff ...
              <key>SecurityType</key>
              <string>WPA</string>
        </dict>
    </dict> -->

Save the file and close any System Preferences windows you have open.

Now this is what is in your new System Preferences > Network, no choices but the one that you want. Viola! Make sure you automatically connect and you're done.

your new network connect menu

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .