4

I just bought the 2560 x 1440 px @ 25 inch (117.5 dpi) Dell U2515H monitor and must say that I'm pretty pleased with the design and quality of the display. Excellent bang for the buck, very thin, frameless bezel, clean backside.

Using the included MiniDisplayPort-to-DisplayPort cable, it allows me to run at native 2560 x 1440 px @ 60 Hz from my MacBook Pro Retina 13" (Late 2013) and an even older MBPR 13" (2011). Both Macs are running the latest version of El Capitan.

I can enable the HiDPI modes using SwitchResX or the Terminal command, but in 1280 x 720 px (HiDPI), the UI becomes too big and one loses too much desktop property.

Question: Is there any way to enable the scaling options („Larger Text“ / „More Space“ and the sizes inbetween) under System Preferences > Displays, as found on the Retina MacBook displays and 4K/5K monitors?

enter image description here

1

Option+click Scaled

You can toggle between Apple’s easy-to-understand “Larger Text”–“More Space” icons mode and the other mode listing specific resolutions. To toggle, hold down the Option key while clicking Scaled radio button.

enter image description here

enter image description here

System Information app

Use the System Information app to see more about your monitor in use.

Choose Apple menu > About this Mac > System Report (button). Click Graphics/Display in the list.

Here is what I see with Retina scaling enabled for my 3840 X 2160 (4K) monitor (Samsung U28E510) on my MacBook Pro Retina Late 2013 with NVIDIA graphics card, in El Capitan.

enter image description here

Retina

Scaled options are Retina-style by default, more commonly known as HiDPI.

The SwitchResX app is not needed to get Retina effects on your external 4K monitor. That app has other benefits, but certainly is not necessary to get Retina/HiDPI as you get that be default from Apple.

Note the checkbox Show low resolution modes in the second screen shot above. Checking that box and choosing a resolution listed with the notation (low resolution) means you are disabling the Retina feature and scaling up the image crudely (wasting pixels).

  • 2
    Thanks for the detailed reply. Unfortunately you've missed the keyword in my initial question/topic headline: Non-4K display. Your U28E510 is a 4K display, my Dell U2515H however is not. DPI-wise it is somewhere between a Non-Retina (Non-4K) and a Retina (4K) display, which is why the HiDPI mode would be really nice to have. I don't see how that can be enabled, there just don't show up any HiDPI options. So for example: the native resolution of the Dell U2515H is 2,560 * 1,440, so 1,280 * 720 HiDPI should be no big deal. – Dr. Woo Oct 20 '16 at 15:11
  • 1
    @Dr.Woo Did you try my advice and Option+click the Scaled radio button? Please edit your Question to include a stern shot of that. You need not have a 4K monitor to get Retina behavior, as Apple’s own laptop screens are not 4K. Your question appears to be unclear. – Basil Bourque Oct 20 '16 at 17:15
  • 2
    Yes, I did try the Option+click on the Scaled radio button (already new that), and while I get offered all kind of resolutions, non of them include the HiDPI tag. What do you mean with „include a stern shot“? (Sorry, not a native speaker). – Dr. Woo Nov 9 '16 at 15:13
  • 2
    @Dr.Woo No, you will not see any “HiDPI” tag. Apple's list of resolutions are Retina (HiDPI) if unmarked. Non-HiDPI will be labeled “low resolution”. These low-res modes are suppressed by default. To access the low-res modes, check the “Show low resolution modes” checkbox seen in screenshot above. This was explained in the last paragraph of my Answer. | That phrase “include a stern shot of that” in my earlier comment should have been “include a screen shot of that”, screen shot. – Basil Bourque Nov 10 '16 at 4:25
  • 1
    Struggling with the same for 2560x1440 to make it 1280x720 HiDPI - apple.stackexchange.com/questions/276205/… . NO success so far. 1280x800 kinda works but is not optimal. OTOH, my 4k monitor works quite nicely at 1280x720 - what is going on that the 2.5k one does not ?? – KarolDepka Mar 13 '17 at 22:21

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .