7

I'm debugging JavaScript on my iPhone and I can't get Safari to stop caching the JavaScript files. I have "Disable Caches" enabled under the develop menu, and have cleared the cache numerous times but as you can see in this screenshot some script files are still cached:

Network debugger

The only way I've found to fully clear the cache is to wipe all content from Safari though my phones settings.

As well, all requests returned by the server prohibit caching through response headers:

Cache-Control: no-cache, no-store, must-revalidate
Pragma: no-cache
Expires: 0
  • 1
    This question isn't specifically about any of the code, so I felt it didn't belong on Stack Exchange. – ecnepsnai Jan 25 '16 at 21:36
1

Disable Caches is for Safari on OS X, not for Safari on your connected iOS device.
You can't disable caches on Safari on iOS.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .