0

I have XQuartz running and I can open xterm if I have started XQuartz just for the first time after rebooting the machine. However, as time passes, I cannot create new xterms. So much so that if I quit current XQuartz and restart just XQuartz, I cannot get any xterm. It is annoying that I have to reboot the machine just to be able to use xterm.

I am running OS X 10.11 El Capitan. I'll appreciate any insight.

Here is the information from pkgutil.

$ pkgutil --file-info /Applications/Utilities/XQuartz.app
volume: /
path: /Applications/Utilities/XQuartz.app

pkgid: org.macosforge.xquartz.pkg
pkg-version: 2.7.86
install-time: 1445273913
uid: 0
gid: 0
mode: 755
  • Which version of Xquartz are you using? And, did you install it directly, or through some kind of port manager? – juandesant Jan 25 '16 at 19:39
  • I am using XQuartz 2.7.8 (xorg-server 1.16.4). It is the same version on two iMacs. I am not sure how did I install it. I thought I did it through App Store but it is not in there. – unxnut Jan 25 '16 at 20:04
  • You can use pkgutil --file-info /Applications/Utilities/XQuartz.app to learn if it was installed by a package —possibly downloaded from xquartz.org—, or macports or similar – juandesant Jan 26 '16 at 15:32
  • Added info into question. – unxnut Jan 26 '16 at 17:15
  • 1
    BTW, does the problem persists if you create a new user, and try to open xterm from it? – juandesant Feb 2 '16 at 10:13
1

Using Keyboard

After selecting/clicking on Xquartz, you can press command + n to create how many new xterm windows you need.

Using Terminal App

open a terminal app and enter the below command

/usr/X11/bin/xterm

hopes this helps.

-1

I've had a similar experience when the computer switched or joined networks. Apparently the hostname is used as part of the authentication process to determine if a client is allowed new windows, and locks that in at start time. If you get a new hostname via DHCP, these credentials become invalid. There were some settings I could do to fix it, but I don't remember them (it was not to disable X11 security completely ;-). Try to manually start an xterm from the shell prompt in the existing xterm and throw the error message into Google - that's what helped me to solve it.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .