6

Here's my first question:

In Lion, if you turn on Filevault, you can no longer modify the System Preferences/Security & Privacy/Require password... after sleep or screensaver. The value is forced to 'immediately' and changes are not saved. If you haven't turned on Filevault, this setting acts as expected.

Has anyone found a workaround?

It's not a security feature, in that you can set the screensaver not to come on for hours (or never), but it sure is annoying for those folks who reach over and wiggle the mouse when the screensaver comes on.

A postscript: my workaround is to change the setting and never close System Preferences. Dumb, but it works.

  • Wow - that is one of the most awesome workarounds for a bug I've seen lately. – bmike Aug 19 '11 at 3:56
  • Hmm, I can't reproduce this here with 10.7.1 and FV2 enabled, changing the "Require password.." settings works just fine. Maybe there is something wrong with your preferences in general. – nohillside Oct 2 '11 at 7:14
  • I'm having the same problem. Writing the pref from the command-line doesn't seem to work. – djc Oct 7 '11 at 19:52
1

Upgrade to Mac OS X 10.7.2 or higher for the Security and Privacy setting "Require password time period after sleep or screen saver begins" to be respected after FileVault is enabled (though I don't see anything about this fix on the download page). There is no longer a need to keep System Preferences open forever (what a silly but effective fix) or any of the other workarounds.

0

I haven't been able to test it on Lion, but this works fine on Snow Leopard for disabling the password requirement on screensaver: defaults -currentHost write com.apple.screensaver askForPassword -int 0

  • 1
    The defaults command shows that the settings that were active before turning on Filevault are still set. The system ignores them and asks for a password as soon as the screensaver has been activated. – zzz Aug 19 '11 at 17:35
0

You can force System Preferences to quit. It doesn't get a chance to reset the the wait before dying.

You can see the current value with: defaults read com.apple.screensaver. Mine now looks like this:

{
    askForPassword = 1;
    askForPasswordDelay = 3600;
    tokenRemovalAction = 0;
}

This also worked for setting the value without the hack of forcing system prefs to quit: defaults -currentHost write com.apple.screensaver askForPasswordDelay -int 3600 and I'd imagine the suggestion to set askForPassword would work too.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .