2

We have been locked out of our iMac running on El Capitan. Basically all known user accounts have disappeared. Only "other" remains which seems to the "system administrator" or "root" and when trying to login with this one, it hangs (endless turning white circle). Have been on forums and tried many of the First Aid (and second aid) tips and tricks, including fsck (where I found out initially "MacHD had been modified", and eventually got to "MacHD seems to be working fine").

Someone suggested the problem may be in Launch Services area and to access the Mac through FireWire and Target Disk Mode, but I don't have the possibility for such connection, plus without step-by-step I am not tech savvy enough to dare the programming challenge it seemed to require.

Any help would be wonderful. I would bring it in, but as always when things fail, several important docs on the hard drive hadn't been backed up yet, so there we are.

  • How are you determining that users are gone? This seems to be clouded by a lack of details on root. Do you enable root or are you using that as a generic term for any administrator user. If you want to transfer data perhaps ask a follow on question since Macs generally have a target disk mode and you can transfer files off the storage without any viable OS stored on local drives. – bmike Jan 25 '16 at 16:49
  • @bmike - on the login page the only profile that shows is "other" which seems to be the Root, cause when we couldn't log in we thought password may have been the problem so searched for answers (when opening in Recovery mode we tried to reset password and only user available/visible was the Root) – cat Jan 25 '16 at 17:03
  • i have since found in single user mode thanks to klanomath that my other users are still in there somewhere. Would love to recup my data and fix everything afterwards, just don't seem to find a way yet. – cat Jan 25 '16 at 17:10
  • Perfect - Single user mode means you can spend 10 minutes to see if the Mac works by making a new admin account. I'll answer and point to links on details... – bmike Jan 25 '16 at 18:20
  • @bmike We already tried the rm ... .AppleSetupDone method as one part of my answer with no pleasant result – klanomath Jan 25 '16 at 18:38
3

According to several sources: Apple discussions or Mac notebooks: Apple Hardware Test may report "HDD" alert the error: error 4HDD/11/40000000:SATA(0,0) may be erroneous or at least unclear/dubious.

It may be related to the vanishing of your users in the Login Screen or not.


Depending on your findings in Single User Mode you have several options:

  • Removing .AppleSetupDone to re-run Setup Assistant

    To remove this file, you have to boot to single user mode by pressing S while booting. After a few moments, you'll see the Mac boot to the command line.

    Check the file system and mount your main volume in read/write mode

    /sbin/fsck -fy
    /sbin/mount -uw /
    

    With the filesystem mounted and accessible, it's time to remove the file so OS X will re-run Setup Assistant:

    rm /var/db/.AppleSetupDone
    

    Reboot your Mac with

    reboot
    

    After rebooting the Setup Assistant will create a new user and setup your system. Choose a user name not used previously. Search for any "old" (in /Users) or moved (elsewhere) previous user folders. In a second step you can change the permissions of the individual user folders and recover all data.

    This might fail if your system is corrupted (bogus LaunchServices etc.)

  • If your system seems to be corrupted, reinstall it:

    Reboot to Recovery Mode by pressing R while booting.

    Open Disk Utility in the main panel and verify/repair your main volume and permissions. Quit Disk Utility.

    Reinstall the system with Reinstall OS X. This shouldn't affect any user data or already installed apps.

  • If the previous step also fails I recommend to slightly resize the main volume, create a new 50 GB volume and install a fresh version of OS X to it. Since you have a Fusion Drive (CoreStorage LVG) you may either use the command line or Disk Utility to resize the main volume. Using Disk Utility choose the Fusion Drive and "Partition" and use the handler to slightly resize the main drive. Then choose the new item "Untitled" and the erase button and rename it to something else but stay with the default format (OS X Extended (Journaled)).

    After successfully installing OS X to the new small volume attach an external drive and save all precious data to it. You may have to adjust the permissions of some of the user folders to accomplish this.

    Finally erase the drive and install a new system. Now either let it check by an Apple authorized technician or at the Apple Genius bar for the errors mentioned at the beginning or continue setting up your system.

  • But i guess this was a panic message. – cat Jan 31 '16 at 19:26
  • am trying this now – cat Jan 31 '16 at 19:40
  • spinning wheel (meanwhile when im typing messages to you I start with "@klanomath" which disappears as soon as I press enter?! Weird no?) – cat Jan 31 '16 at 19:43
  • booting to internet recovery mode doesn't seem to work... wheel is still spinning, best to give up i guess and bring it in ;-( – cat Jan 31 '16 at 19:53
  • not sure - where can I find the info – cat Jan 31 '16 at 20:04
1

I just had my main user/admin account disappear on El Capitain 10.11.6

I had to commandR at boot up to reset the System Administrator (root) account.

I then was able to re-create the user account, it said files already existed and asked to reattach. So I didn't lose any files, but lost a lot of work time. I was on the phone with an Apple tech who said I needed to update my apps (which was GarageBand, iMovie, and a small OS security update).

0

The simplest fix is to either connect the Mac to another Mac with yours in Target Disk Mode to save the files you need or to make a new admin account.

How to set single / target disk:

How to make a new admin account by deleting the /var/db/.AppleSetupDone file while booted in single user mode:

Either way, you'll have a functioning user account to save things and then piece together whether you fix the iMac or wipe and reinstall once your files are backed up properly.

  • thx. looking into the first one, as I tried the second one already but won't get passed language selection (then it hangs) – cat Jan 25 '16 at 18:29
  • @cat If your system can't make a new admin user, then far more is broken than just missing user records. I'd get it to someone that does data recovery if you are willing to pay for results and/or try recovery yourself in target disk mode. If the drive is failing, all the time you spend running the drive could be making recovery less likely. Unless you have a good reason to suspect why so much data was deleted, hardware failure is the likely culprit here. – bmike Jan 25 '16 at 18:34
  • @mike you may be right, but so far all the feedback I got from the computer was that the HD was fine, seems to be ok etc... I follow the few leads I got in first instance. Recovery via Target disk mode requires i connect 2 macs via Firewire/Thunderbolt none of which I have(yet) – cat Jan 25 '16 at 18:51
0

I have this same problem and it seems to occur every few months. I have no reason why, but its a pain because people can no longer log on.

Here is the solution. Follow these steps to restore it.

  • Quit Server.app

  • On the Open Directory Server, execute these Terminal commands:

      - sudo mkdir /var/db/openldap/migration/

      - sudo touch /var/db/openldap/migration/.rekerberize

      - sudo slapconfig -firstboot

  • Open Server.app

-1

To make all the complicated lives of IT gurus easier, *

they are all in the Finder/Preference

*, just pick and click. Not Apple/Preference.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .