5

I'm using iOS 9.2 and I once accidentally tapped “don't allow” or something similar when WhatsApp was opening a link for Citymapper. It used to launch the Citymapper app, but now it goes to the less useful web interface.

I've looked through all the settings but I can't find any record of this preference to reset the permission.

Metadata on page:

<meta property="al:ios:url" content="citymapper://directions?endcoord=51.56819%2C-0.086512&region_id=uk-london" />
<meta property="al:ios:app_store_id" content="469463298" />
<meta property="al:ios:app_name" content="Citymapper" />
<meta property="al:android:package" content="com.citymapper.app.release" />
<meta property="al:android:app_name" content="Citymapper" />
<meta property="al:android:url" content="citymapper://directions?endcoord=51.56819%2C-0.086512&region_id=uk-london" />
6
  • You probably should be able to uninstall whatsapp, and then reinstall it to fix your issue. But, this is a bit extreme, and there is most likely a better solution out there.
    – Flare Cat
    Jan 23 '16 at 19:37
  • I tried this, didn't seem to reset anything. Links to citymapper still open in web.
    – Tom
    Feb 1 '16 at 11:18
  • If you would like more attention to this question (since I think it is a good one), I would suggest starting a bounty.
    – Flare Cat
    Feb 3 '16 at 0:53
  • I've tested your issue and I cant replicate it. I installed CityMapper and Whatsapp and tried to load a citymapper:// url from Whatsapp. I pressed Cancel on the popup asking for permission to open the Citymapper App and nothing happened. Then I pressed the link again and the same popup appeared. I would suggest updating to the latest iOS version and the latest version of both apps.
    – dordio
    Feb 3 '16 at 13:01
  • have you tried reinstalling the citymapper app? Feb 4 '16 at 10:48
1

If I'm reading the documentation correctly, when the web interface pops up in Safari, there should be a banner across the top of the page that essentially says, "Hey, you could view this info in the app instead!" If you tap OPEN on that banner, it's supposed to re-establish the universal linking to the app instead of the website. Here it is in Apple's words:

When a user taps a universal link that [an app] handle[s], iOS also examines the user’s recent choices to determine whether to open [the] app or [the] website. For example, a user who has tapped a universal link to open [the] app can later choose to open [the] website in Safari by tapping a breadcrumb button in the status bar. After the user makes this choice, iOS continues to open [the] website in Safari until the user chooses to open [the] app by tapping OPEN in the Smart App Banner on the webpage.

Source: Universal Links in Apple's App Search Programming Guide

1
  • Good answer, but the link appears not to be a universal link, just a web link that is then triggering the citymapper app opening like this one: citymapper.com/eta/Tfkagpb. The page contains this metadata I've added to the question.
    – Tom
    Feb 6 '16 at 17:28
0

Try long pressing the link in what's app. you should then get a choice to open in the app or in safari.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .