0

I have upgraded to El Capitan, but I was having this problem for a while, where the desktop background doesn’t display. The folders have white letters, and the background is white, and this makes everything difficult to read. The background image doesn't change immediately, I have to log out, and log back in. I can see it has changed, on the login screen, and after I have logged in. But at some point, the screen turns white, and thus the problem.

I have turned off all the start up applications, and the problem remains.

I have looked for view options in Finder, but I cannot figure out why the desktop remains white.

I have tried the normal ways of changing desktop background, but it doesn’t work. Alternatively, I can not see it, because something is blocking it? That is a guess.

Inverting colours in the accessibility menu doesn't help, as inverted colours mean I'm looking at black on black instead of white on white.

I created a new user. The new user doesn’t have this problem, their desktop is visible.

3
  • Are you perhaps running an app that messes with the Desktop? Two possible examples I can think of are Desktop Curtain and Path Finder. – 75th Trombone Jan 26 '16 at 20:11
  • Have you tried booting in safe mode (with the Shift key held down) to see if the problem persists? If it does then its most likely due to a corrupted preferences file- perhaps ~/Library/Preferences/com.apple.desktop.plist. Delete that file then restart in normal mode to see if that was the cause and let us know the result, please. – KarlC Jan 27 '16 at 4:59
  • The Desktop wallpaper settings are stored in ~/Library/Application Support/Dock/desktoppicture.db since, I believe, Yosemite. You can try deleting that file and restarting your Mac. – MorganR Jan 28 '16 at 11:09
1

I deleted ~/Library/Preferences/com.apple.desktop.plist which seemed to help momentarily, but the the problem began again. in that time, I noticed an app called "DeskShade" that was running, and said wtf is that? So I did sudo rm -rf DeskShade.app/ I rebooted, and my desktop is back. It's been good for about 30 minutes, hopefully removing this app is the solution.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .