0

I have a clean installation of El Capitan with VMware Fusion Pro 8 and Windows 10 Pro. I use Fusion in full screen, and the windows keyboard command Control + Command+ D is used to create a new desktop, however when pressing this command, the mouse curser changes to the Mac OS cursor, and nothing happens. It seems Mac OS is digesting the command and not allowing the virtual machine to receive it.

Interestingly:

  • The VM receives other commands, like Control + Command+ Left
  • All commands 'disableable' through preferences in both keyboard and accessibility are disabled, with the exception of Command + Option + Left, and Command + Option + Right to change full screen applications.
  • The only reference I have found to it, is a Document Shortcut, which I would expect to be consumed via the application in focus.

How can this renegade command be rectified?

0

The key combination ctrlcmdD is a system wide shortcut to show or hide the definition of a selected word/words. This even works in VMware. As a last resort the definition of the name of your virtual machine will be shown.

To disable the shortcut, open Terminal and enter:

defaults write com.apple.symbolichotkeys AppleSymbolicHotKeys -dict-add 70 '<dict><key>enabled</key><false/></dict>'

This will add the key 70 to the file com.apple.symbolichotkeys.plist and disable the shortcut. After a reboot you will be able to use the above shortcut in fullscreen mode in Windows 10.

You may get a similar result by installing Karabiner and adding a special keycode.

| improve this answer | |
  • I wish I code further upvote this. Thank you so much for saving my sanity. Out of interest, is there any source of information like this in the apple world - much like MSDN, where I could piece together this wizardry on my own? – Éliette Jan 24 '16 at 6:55
  • @Gui Some resources exist (like Apple Developer) but I doubt that they are comparable to MSDN – klanomath Jan 24 '16 at 9:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .