2

I have been using the StarTech USB 3.0 Gigabit Ethernet dongle which was working until I upgraded to the latest OSX Beta 10.11.4. Now it has stopped working--not even showing any indicator lights when plugged in.

I reinstalled the latest drivers on their site but still nothing. When I try to check kernel extensions with kextstat but didn't see the driver there. However, when I check extensions in the system profiler, and i see this

System Profiler -- Extensions

Does anyone know what I could do to make sure the driver is loaded so I can use the dongle? Thank you!

  • Since you mention that you are running it on beta software, have you verified that it is known working on another machine? – smoooosher Jan 26 '16 at 23:38
  • I haven't verified, and I guess you're right...I should have checked that. – Andrew Patterson Jan 27 '16 at 17:26
  • I emailed ASIX and they sent me a new driver about a week later which works really well. I'm new to stackexchange, so I'll ask you guys: should I leave a link to it here in the comments or create a new response? – Andrew Patterson Jan 27 '16 at 17:28
  • it is perfectly acceptable to answer your own question. Since it does resolve the issue, I'd suggest you post it as an answer and then accept the answer as correct. Glad to hear it's working! – smoooosher Jan 28 '16 at 18:22
0
  1. In Terminal.app issue the command:

    sudo nvram boot-args="kext-dev-mode=1 rootless=0"
    
  2. Remove the NetworkInterfaces.plist file to regenerate a new one:

    /Library/Preferences/SystemConfiguration/NetworkInterfaces.plist
    
  3. Remove the device from System Preferences.app > Network

  4. Reboot your Mac
  5. Plug-in USB dongle
  6. Re-add device in the System Preferences.app > Network
  • I have the same problem. Graham's advice doesn't change anything... It's not possible to add again the network interface, AX18879 visible in System Profiler – Pavol C Jan 26 '16 at 23:35
  • Pavol, the same thing happened to me. When I go to re-add the USB dongle in System Preferences.app > Network the option is not available under Interface. – Andrew Patterson Jan 27 '16 at 17:12
  • I have the same issue again ,after i update "little snitch" go to asix.com.tw/download.php?sub=driverdetail&PItemID=131 download newest driver , and worked . – Kaien Yu Jan 29 '16 at 3:56
0

It seems that the certificate sign check is broken in 10.11.4 beta (2 too). Probably all third-party drivers are signed by an "invalid signature" For details:

https://forums.developer.apple.com/thread/30477

https://forums.developer.apple.com/message/103541#103541

There is a workaround: disable System integrity protection, the drivers will work then: Configuring System Integrity Protection.html

  • Thanks for the suggestion. I am nervous about disabling System integrity protection, as I don't know what unintended security consequences this might create. Would this create more vulnerabilities on my machine? – Andrew Patterson Jan 27 '16 at 17:14
0

Looks like they posted the updated driver as of 01/28/2016:

http://www.asix.com.tw/download.php?sub=driverdetail&PItemID=131

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .