6

I would like to ask you what is wrong with my Xcode 4.1. Every time I launch it, it show me that there are "No recents" nevertheless the fact that I have created lots of projects.

P.S.:

defaults write com.apple.Xcode NSRecentDocumentsLimit X

does not work

Thank you in advance.

  • Have you tried any steps to isolate the issue? Does making a new user account and creating one or two projects have the same bad behavior? – bmike Aug 18 '11 at 16:47
  • I have, but there is still the same issue :( – Arthur Aug 18 '11 at 16:49
  • If you would kindly edit the question to summarize the steps - it will help me see if perhaps I know one you missed. Also a wild guess - can I assume your Xcode is installed on the good disk and does it have less than 20G free? – bmike Aug 18 '11 at 16:53
  • I actually tried "defaults write com.apple.Xcode NSRecentDocumentsLimit 5" but there was no response, same "No recents" and actually created some new projects which also did not change anything. Talking about, installation of the Xcode there is still lots of space - 408.48 GB available. – Arthur Aug 18 '11 at 16:59
6

Recent items menus can be tied to the "Number of recent items" preferences for the Finder in System Preferences, but this is particularly true for Apple's software now. Setting the OS preference for "Documents" to anything other than "None" will activate that feature in Xcode. I wouldn't have done it that way either.

enter image description here

You might have to Quit and Discard Windows Command-Option-Q, change the number in the general pane and relaunch Xcode. It's a bit convoluted to get the change active with all the recent "save your workspace" changes in Lion.

  • How to find this "Number of recent items" in "System Preferences"? – Arthur Aug 18 '11 at 17:00

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .