1

I have noticed something that really annoys me. Say I have some applications running and then I select a particular one using Dock. This application appears on the screen but does not receive focus (windows is displayed as inactive). So, when I type something input is not going to the foremost window.

For more clarification I can say that I always encounter this when focusing Terminal app that is not maximized - window is shown, but no focus on it. Moreover, when I click on an app icon in the Dock and this app was maximized, I have to click twice to see this app.

Have anyone encountered the same?

UPD: the problem relates to switching from full-screen app to non full-screen and vice versa. Switching from one full screen app to another full screen app or from one non-full screen to another non-full screen does not reproduce the problem

  • It's something I've noticed occasionally happens - used to be more so on Mavericks. Try killing the Dock killall -KILL Dock & check again. – Tetsujin Jan 20 '16 at 10:34
  • It seems that it didn't help. – Ivan Jan 20 '16 at 17:45
  • Does rebooting restore the correct behaviour? – Tetsujin Jan 20 '16 at 17:52
  • It seems that not :( – Ivan Jan 20 '16 at 21:09
  • Then I'd check it in the guest account or make a new admin account & test there. – Tetsujin Jan 20 '16 at 21:37
0

I would also take a look at bettertouchtool although january 2016 is the last month it will be freeware. I believe it has an option for it

  • I'm not sure that I need to use external app for the behavior that should be build-in. – Ivan Jan 20 '16 at 17:46
  • True that, however it was a thought that came up. Delete this answer if u see fit – dimitrieh Jan 20 '16 at 17:50
0

Found solution myself. In system settings on the Mission Control tab the second option of the top group must be checked. I don't know exactly how it is in English, it shall be something like 'Switch to space with application windows when switching to an application' or something like that.

I used this as a tip, it says about the third checkbox, but in my case the second one has solved my trouble.

  • It reads "When switching to an application, switch to a Space with open windows for the application." You should update your question to make it clear that this has to do only with apps/windows in different spaces. – gardenhead Feb 2 '16 at 1:08
  • I do not agree. I do not use spaces at all, so my problem is not related to them, but ticking this checkbox solved it. – Ivan Feb 3 '16 at 12:37

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .