When I want to insert a floating number in Apple Numbers 3.6.1 in OS X 10.10.5 while my primary preferred language in Language & Region is Persian(فارسی), the number is interpreted as a string value.

enter image description here

In these screenshots the right cell has the formula of B2 ÷ 2 while B2 is the left cell. I typed ۱.۲۳ (that is 1.23 in Persian) in B2 with Persian keyboard layout and an error is occurred.

enter image description here

The result is the same when i type the number with English keyboard layout.

enter image description here

How can i enter a floating point number?


Note that in Persian language the floating point sign is represented with ,. So the problem can be solved by entering the number as ۱,۲۳ or 1,23.

In the first form when you want to enter the floating point sign, switch the keyboard layout to English then insert ‍, and then switch it back to Persian and insert the remaining fraction part.

enter image description here enter image description here

  • Have you tried it with "/"? Because the actual decimal separator in Persian is slash, not a dot, not a comma.
    – Neeku
    Jul 5 '19 at 11:11

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .