I recently got a new MBP. My older MBP (early 2011, 13") has some stuff on it I would like to transfer.

I tried using migration assistant, but it appears that they need the same OS versions. I tried upgrading the old MBP to El Capitan... it seemed to go trough the process, but now the old machine will not boot.

I can get into single user mode; I ran fsck -fy and it said everything was OK.

When trying to log in, the progress bar chugs along slowly for 30 minutes or so then it reboots.

Booting with verbose set, it seems to hang at SNB Framebuffer did not show up,unload. Some googling turned up some hackintosh threads stating that this meant it can't find the graphics card.

I have not modified the machine in any way. One thing to note, though, is that the battery isn't charging and needs to be replaced (I have it plugged in to power).

Any suggestions or recommendations would be appreciated.


Turns out it was the battery.

I was having the dreaded kernel_task problem where the CPU was using between 300 and 1,200 percent. I assume this was what was causing the mentioned error (among other problems).

After disconnecting the battery, the laptop booted fine and I was able to transfer my data.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .