14

How can I turn off automatic personal hotspot activation when connecting an iPhone to a computer (Windows in this case)? I had it plugged in when downloading an iOS update and it downloaded the update over cellular data instead of home Wi-Fi.

I understand I can turn it off manually each time by going into settings, but how can I have it not turn on automatically so that I can only turn it on manually as desired to prevent accidental usage?

5 Answers 5

7
+50

The problem isn't on your iPhone, it's on your Windows computer using the USB tether rather than Wi-Fi. You need to set the network interface priority on your Wi-Fi to be higher than the USB device, or the USB device to be lower, so that it will only use the tether if it isn't connected to Wi-Fi.

Make sure to connect the iPhone first. Directions for Windows 7 are here (these will likely work on newer versions as well):

Alternately, you could disable the connection on your Windows computer but you'll still have to manually turn it on each time so I think the above fix will provide the result you want.

9
  • 2
    How can we do this on Windows 10? I've looked at every setting in the Control Panel under "Network and Sharing Center", but there's no option to change connection priorities.
    – Zesty
    Nov 8, 2016 at 11:19
  • 1
    There seems to be some issues with this on Win 10. Here is the best fix I could find blogs.technet.microsoft.com/networking/2015/08/14/… Nov 23, 2016 at 23:56
  • 1
    Does this help with setting the priority in Win 10? community.spiceworks.com/topic/… Oct 14, 2017 at 17:07
  • 1
    For windows 10, this is a good guide. windowscentral.com/…
    – anacron
    Dec 8, 2020 at 9:00
  • 1
    Nice guide, @anacron Thanks! Very disturbing at some point again how Windows does what it wants for you. Clearly, connecting a external device such as iPhone SHOULD NOT at default take control of the connection. This is an integrity issue if you ask me if not security. Gladly it can be changed but deep under the hood, which is not the way. It should be visible to everyone at the Wi-Fi menu. It still shows me iPhone>Wi-Fi despite having changed it. Maybe reboot needed.
    – user205238
    Dec 4, 2021 at 14:03
2

Here are instructions how to use the command line to change the priority of the network interface to get Windows to route the traffic through WIFI adapter instead of iPhone. This is tested on Windows 10.

  1. Open up PowerShell with admin rights
  2. Use the route print to find the correct interface

enter image description here

  1. Check the index (the first column) for the "Apple mobile device ethernet". In my case this is 25. Use then Get-NetIPInterface command to see associated metrics values for each interface

enter image description here

  1. Check the InterfaceMetric value. The interfaces will be ordered using this value, so you want to change the Apple device to to use a value higher than for example your WIFI connection. In my case both Apple and WIFI share the value 35, so to guarantee the order I want to put the Apple device value to 45.

  2. Use Set-NetIPInterface command to specify the value:

    Set-NetIPInterface -InterfaceIndex 25 -InterfaceMetric 45

  3. Running again the route print command shows that in my case the Apple Mobile device ethernet and my WLAN adapter has now changed the positions, meaning Windows will route the traffic through the WIFI instead of via iPhone

enter image description here

2
  • Do you have to do this every reboot or just one time?
    – g491
    May 11, 2017 at 13:00
  • 2
    @g491 Looks like this was not a permanent fix, this no longer worked after reboot. One problem is also that this is using the interface id (25), which is likely to change at some point. You could probably replace that with Set-NetIPInterface -InterfaceAlias "Apple Mobile Device Ethernet" -InterfaceMetric 45 The command Get-NetIPInterface shows the list of interfaces. Another issue is that this maybe cannot be done at the boot time, but only when iPhone is connected. There's some trick for running scheduled task when connection becomes available and that might be useful here. Jun 4, 2017 at 18:23
2

For a Mac it's quite simple:

While your iPhone is connected to your computer go into Network Preferences and remove the iPhone from the list of network interfaces.

I’m not sure how to change the order of connections however. That would seem more useful. But this is a quick fix until you use your phone again as hotspot through USB.

2
  • 2
    In the Network Preferences under the list of the network interfaces, click the little gear icon and from the drop down menu choose "Set Service Order..." In the dialog you can use drag and drop to reorder the services. Sep 25, 2018 at 12:43
  • MacOS provides an optional checkbox now for the iPhone USB connection that reads "Disable unless needed" and will only connect to your iPhone if no other internet connections are available. support.apple.com/en-ie/guide/mac-help/mchl7594e36f/mac Jul 21, 2020 at 18:52
1

The iOS device will use use data over Personal Hotspot if it is turned on and the device is connect to a computer via USB cable. Here is the documentation from Apple:

When your connect your iPhone or iPad to your computer with a USB cable, Personal Hotspot automatically shares an Internet connection with your computer. For example, when you connect your iPhone to your computer to charge, your computer will use Internet from Personal Hotspot on your iPhone. To avoid unnecessary data charges, turn off Personal Hotspot when it isn't in use.

The only way to prevent unwanted data usage when using USB is to turn off Personal Hotspot via Settings > Personal Hotspot.

1
  • 1
    Data is only used if the connection has the highest network interface priority. The exception is if the connection you're trying to make is to the phones IP address. Feb 21, 2016 at 5:51
-1

I think the above answers are incorrect. My iphone 5S under OS 11.2.5 automatically turned on the personal hot spot feature when I connected it to my Windows 7 laptop. My daughter had a similar experience with an iphone SE and a Mac powerbook. This suggests that it has nothing to do with windows per se. It is a misfeature of recent iOS versions

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .