Darktable mysteriously stopped working on me yesterday. I tried restarting my iMac, deleting and re-installing darkable and finally after going through some forums I tried running through the terminal: open -a darktable
That returned
LSOpenURLsWithRole() failed for the application /Applications/photo programs/darktable.app with error -10810
I tried chmod +x /Applications/darktable.app/Contents/MacOS/darktable
I also tried chmod +x '/Applications/photo programs/darktable.app/'

I have tried with several versions of Darktable and am beginning to think it has nothing to do with Darktable and something to do with MacOS...

Any ideas?

1 Answer 1


I found the solution... Here is how I found it: I tried the temporary solution suggested in this post: iTunes on iMac won't start up after upgrade (error -10699)
- execute the binary directly by running the binary in the terminal.


That gave me this error:

[init] the database lock file contains a pid that seems to be alive in your system: 456
[init] database is locked, probably another process is already using it

As stated in http://redmine.darktable.org/issues/10164, there was a lock file left behind in /Users/{HOME_USER}/.config/darktable/library.db.lock.

All I had to do was delete that file and up it was running again... Sometimes it's just a little too simple. :/

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .