4

Yesterday, my computer developed two worrying problems that occurred simultaneously:

  • My computer began to crash at random times (solved, maybe)
  • My Wi-Fi turns off frequently and cannot be turned back on (unsolved)

Some useful information that may be of assistance:

  • Network is inaccessible
  • The Wi-Fi symbol is unfilled (it's really off, not just disconnected)
  • ifconfig reports that en0 (the Wi-Fi interface) is up, but status is inactive
  • The Network tag under System Report... still shows the correct card type and firmware version (AirPort Extreme and Broadcom BCM43xx 1.0, respectively), but the status is Off.
  • AirPort Utility is fully updated
  • All VPNs (of which there are one) are disabled (by me), and all other network types turned off (by me)

If any further information is needed, please let me know - I'll see what I can do to get it from the computer. Any advice would be greatly appreciated, as I dearly need this laptop for school.

EDIT:

I have worked a bandaid solution of using my cell phone as a Bluetooth NAP device, so I should be able to upload any information that you need.

EDIT 2:

Resetting both PRAM and SMC did not successfully fix the issue. My computer actually entered an unusable state today, so I'm afraid that no further tests will help, and, at this point, I'm planning to replace the laptop. Any further advice would be appreciated for future use.

4

My AirPort Wireless card was broken

Turns out a spider crawled into my computer, nested itself under the wireless card, and died in direct contact with the wireless card. Go figure. The guy who looked at it said there was water damage (ew), and, after disabling the wireless card (software-wise), my crashes stopped as well.

The crashes were the main reason for him to suspect that the wireless card had issues, because the kernel was throwing fatal errors all over the place. If this happens to anyone else (and you know it's the wireless card), what you can do is the following:

  1. Open Terminal.
  2. Use ifconfig to turn the wifi interface to down (should be en0, so using sudo ifconfig en0 down should work)
    • This makes the computer stop querying the faulty device.
  3. Go to Network in System Preferences.
  4. Remove the Wi-Fi interface (hit the minus button while highlighting it in the leftmost column).
    • This made my computer stop occasionally crashing at boot.

I know that it was throwing fatal errors because, even though they weren't visible in the kernel logs, when I booted in safe mode, it threw about 50 errors in a second all relating to AirPort Wireless from ARPI.

I'm working on replacing the card - I hope this helps someone else.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .