1

I have a consistent issue with the "Thunderbolt Firmware Update 1.2" showing up endlessly in the App Store, but more importantly, after installing it earlier today, my Thunderbolt ports no longer work.

System Report says "No hardware was found," so the OS isn't seeing the ports themselves. I've tried using my Windows 10 partition, but they won't function, meaning the issue isn't OS specific. PRAM/NVRAM and SMC resets had no impact.

In addition, I did a full clean install two months ago where I know I did all Software Updates for 10.11.

According to the App Store, I've installed the 1.2 update 8 times now today.

I investigated the installer for my model's firmware at https://support.apple.com/en-us/HT201518, but the iMac13,2 with firmware IM131.010A.B09 (2015-002) installer requires 10.9. I'm on 10.11.2 and trying to install 10.9 for the express purpose of getting a firmware update to reinstall seems rather foolish.

When I found the package installer, it warned me that it was an expired certificate and designed for 10.8.5 and that it would damage the machine if I ran it on 10.11.2. I decided to try this anyway and the install failed almost instantly (Never even rebooted). I also cleared my App Store cache to attempt to remove the previous version of the update done on the App Store to redownload it. No effect.

I've gone though the various steps in https://support.apple.com/en-us/HT203758, but I've seen no change.

Any advice would be greatly appreciated.

(Please note this is for a 27" iMac and not the Thunderbolt Display. Apple decided to have v1.2 for both.)

You must log in to answer this question.

protected by Community May 25 '16 at 5:51

Thank you for your interest in this question. Because it has attracted low-quality or spam answers that had to be removed, posting an answer now requires 10 reputation on this site (the association bonus does not count).

Would you like to answer one of these unanswered questions instead?

Browse other questions tagged .