1

I used my old Mac which showed me English when I browsed through Mac App Store. However, after I purchased my new Mac and ported all the data using Time Machine, the Mac App Store suddenly shows me Japanese for some reasons.

I use English in OS Settings and everything works fine except the Mac App Store. I live in Japan, which is likely the possible reason it shows me Japanese.

Why do Apple use the different language only on the Mac App Store? And how can I resolve the issue?

3

After I fought with the issue for a few hours, I found the solution.

  1. Open Mac App Store and log out of the account.

  2. Restart your Mac.

  3. Log in to the account again.

You might have to log out of the account first before restarting, for your information.


UPDATE

However, while the solution here worked in my OS X, it's not the case in iOS. In my iPhone, which is set to Italian, the iOS App Store displays English, while my iPad that uses Spanish displays Japanese. This is so frustrating bug in Apple; I don't get to how this can be resolved...

1

There was an answer here: https://superuser.com/questions/412854/appstore-how-to-use-english-only-interface

Here is what was said there:

As far as I know, the language of the AppStore App is always determined by the country in which your account was registered. The AppStore app is basically just a webview which means that the localization is done by the server and not your mac, in order to change the language to english you'll have to create an english account. You could also change the region of your account in the account settings, but that would make it impossible to use a foreign credit card. There's also a thread on Apple's Support Communities Board about this: https://discussions.apple.com/thread/3797598?start=0&tstart=0

  • 1
    The statement there is wrong. As I said the store showed English in my old Mac all the while I did never leave Japan. Also if they do so their decision to just rely on the geographical location to assign the language is so foolish. – Blaszard Jan 17 '16 at 13:43

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .