1

I am trying to connect to a web server (nginx) on OS X El Capitan - on local wifi from an iOS device. I know from earlier that this is not easy. Tried this without success.

Have you come across anything that works?

1

Not a great solution, but have you tried turning off the firewall?

If that works, then try the following, which may prompt you to allow nginx to bypass the OS X firewall: nginx -g "daemon off;"; this will make nginx run in the foreground instead of with the daemon, which seemed to help OS X recognize that it needs firewall permissions.

If you're not getting that popup, try turning off the Automatically allow signed applications option in System Preferences -> Security & Privacy -> Firewall -> Firewall options..., then toggle the firewall off and back on, and toggle the "lock" off and back on (lower left hand corner if you have it set to require admin password to modify security preferences).

Once I got it to give me the popup and I clicked Allow, I found it would let me access nginx for that session.

  • It works when you turn off the firewall. That will not work for me. I found that the following worked: sudo cp /usr/local/opt/nginx/*.plist /Library/LaunchDaemons sudo launchctl load -w /Library/LaunchDaemons/homebrew.mxcl.nginx.plist – Chris G. Feb 5 '16 at 12:28
  • Added an answer. Easier to read :-) Let me know if it works? – Chris G. Feb 5 '16 at 12:32
0
sudo cp /usr/local/opt/nginx/*.plist /Library/LaunchDaemons
sudo launchctl load -w /Library/LaunchDaemons/homebrew.mxcl.nginx.plist
  • Please add a complete answer. Or at least explain what your are doing. A less knowledgeable person has little use for the commands listed. – klanomath Feb 5 '16 at 13:05

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .