1

I upgraded to El Capitan in my new Macbook Air. El Capitan does not allow to use /usr/texbin/ for storage so LaTeX community had to move their files to /Library/TeX. MacTeX 2015 is not fully compatible with El Capitan. There is at least some path reconfigurations which has to be done in individual programs described in the guide. However, I have not succeeded in getting MacTeX fully working in El Capitan.

Fixing LaTeX in El Capitan

All stages went right but not the following with TeX Live Utility. I am doing the step in the guide MacTEX-2015 and El Capitan (page 3)

For previous versions of TEX Live Utility open TEX Live Utility→Preferences and click on the Choose. . . button as in Figure (4). That opens a file chooser. Type Shift-Cmd-G, enter /Library/TeX into the dialog box as shown in Figure (5) and then press Return. Finally DoubleClick on texbin.

I get

enter image description here

After Unsuccessful Setup-2015.pkg

I run rm ~/Library/Preferences/com.googlecode.mactlmgr.tlu.plist to delete the changes made by the applicaiton Setup-2015.pkg proposed by hakaze, because of infinity loop when starting Tex-live with those changes. I found the Library/TeX/texbin eventually.


How can you set up MacTeX 2015 successfully in El Capitan?

  • 1
    You probably should run the 'Setup-2015' app (within the Applications/TeX folder) which fixes paths and permissions for the MacTeX installation and GUI programs under El Capitan. This fixed my issues with TeXLiveUtility amongst other things. – hakaze Jan 17 '16 at 9:15
  • Which path is defined for TeX programs in Tex Live Utility -> Preferences? – nohillside Jan 17 '16 at 10:59
  • 1
    @Masi The setup package is part of the normal MacTeX installation and should be found here: /Applications/TeX/Setup-2015.pkg – hakaze Jan 17 '16 at 12:12
  • 1
    @Masi You can try to delete TLU's preferences (its default will be re-created at start-up): ~/Library/Preferences/com.googlecode.mactlmgr.tlu.plist – hakaze Jan 18 '16 at 10:48
  • 1
    You are looking at two different folders here. The second screenshot is showing /Applications/TeX, the Terminal output is from /Library/TeX. No need to enable hidden files/folders here, I would be more concerned if both would be the same... – nohillside Jan 18 '16 at 12:56
2

You are misreading the guide when defining the path for TeX programs in TeX Live Utility.

  • In TeX Live Utility, open Preferences
  • Click on "Choose"
  • Do one of the following
    • press Shift-Cmd-G, type /Libary/TeX, click on "Go", double-click on texbin and then click on "Choose"
    • press Shift-Cmd-G, type /Libary/TeX/texbin, click on "Go" and then click on "Choose"
  • I updated the body of the question. I see no /Library/TeX/texbin in the system. I installed MacTeX 2015 by clicking everything. Apparently, something went wrong there. What do you think? – Léo Léopold Hertz 준영 Jan 18 '16 at 12:32
  • Based on the screenshot in the question, you are looking for texbin in /Applications/TeX, not in /Library/TeX. Maybe run ls -al /Library/TeX and add output to the question. – nohillside Jan 18 '16 at 12:35
  • 1
    @masi So texbin is where it should be :-) Can you setup TeX Live Utility now as well? – nohillside Jan 18 '16 at 12:54
  • Thank you for your answer and patience! Now, the Finder search also works for .tex files. It was a complication of unsuccessful MacTeX 2015 installation in El Capitan. – Léo Léopold Hertz 준영 Jan 18 '16 at 13:12

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .