0

I have a late 2012 model iMac that I'm preparing to sell. I want to reset it to factory defaults, so Internet Recovery sounds perfect. However, Cmd + Option + R during boot does not work. For that matter, Cmd + R doesn't either. How can I enter Internet Recovery?

  • 1
    You don't mention what OS your iMac has currently installed but if you have no recovery partition it sounds like you have 10.6 or before. If that's the case you'll need to use the install media that came with the system to boot from in order to do a wipe & reinstall. – KarlC Jan 16 '16 at 1:19
  • I was running Yosemite. The machine shipped with Mountain Lion. – bmatcuk Jan 17 '16 at 22:36
  • Have you tried using the App Store to download a new installer for El Cap & install that to give you the functional restore partition from which you can then wipe the boot partition & do a clean reinstall? – KarlC Jan 19 '16 at 8:58
  • The problem wasn't that the restore partition was missing or broken, it's that the usual ways of entering it (Cmd+R / Cmd+Option+R) didn't work. My answer below solved the issue. – bmatcuk Jan 20 '16 at 17:41
0

If you hold Option while booting, a screen will show up that gives you the option to boot into OSX or enter into Recovery (or boot into Windows, if you've installed bootcamp). This is Recovery option is the normal kind of recovery that will reinstall your current OS. This is not Internet Recovery.

However, on this screen, if you press Cmd + Option + R, this will boot into Internet Recovery.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .