0

Very similar problem as this question, only the display itself is working on the thunderbolt monitor (I only have one, unlike the linked question which had two) with a MacBook Pro (Retina, 15-inch, Early 2013). No camera, no audio, no power to USB ports on the display. If I disconnect the thunderbolt display from the MBP, then power does go to the USB ports.

OS X 10.10.5 (14F1509)

(more details below which probably don't amount to much)

This is actually the 2nd Thunderbolt monitor I've had recently. My company exchanged out my previous one, which had similar issues. The prior Thunderbolt was fine, then one day the display would not turn on, attached devices no longer received an active charge. Power would return to USB ports if display was unplugged from the MBP. Then a day or two later, everything went back to working, but the new monitor had already shipped out.

Replacement monitor worked fine the first day, then (of course) the day I shipped back the prior one, started acting consistently as described above - display only, no camera, audio or usb power.

I tried the SMC reset steps (about three times, in case it was sensitive to pressing all 4 keys "at the same time" in just the right way). That hasn't worked.

  • Co-worker dug up this link, I gave it a shot, but no luck: discussions.apple.com/message/28208703#28208703 Also, it takes about 15 seconds for the display to come on. Like it needs to think about it. I normally power the laptop with the thunderbolt cable, though it has the older style mag connector, and I have a converter on it. I tried powering the laptop with my more modern plug that has the proper mag connector, but that hasn't mattered either. – chrismo Jan 15 '16 at 22:17
1

There is a known similar issue with certain 27' Thunderbolt displays going black, and having connection issues. https://support.apple.com/en-us/HT204450

Can you check the firmware version of the Thunderbolt display?

Apple Menu > About this Mac > System Report > Thunderbolt (from left sidebar) > Thunderbolt Display.

The latest firmware version should be 26.2 and the latest Port Micro Firmware Version should be 2.0.7.

Thunderbolt Firmware Version in System Report

  • Interesting, didn't know about this. But looks like I'm up-to-date. <pre> Thunderbolt Display: Vendor Name: Apple Inc. Device Name: Thunderbolt Display Vendor ID: 0x1 Device ID: 0x8002 Device Revision: 0x1 UID: 0x0001000100369860 Route String: 4 Firmware Version: 26.2 Port (Upstream): Status: Device connected Link Status: 0x1 / 0x2 Speed: Up to 10 Gb/s x2 Port Micro Firmware Version: 2.0.7 Port: Status: No device connected Link Status: 0x7 Speed: Up to 10 Gb/s x2 Port Micro Firmware Version: 2.0.7 </pre> – chrismo Jan 15 '16 at 21:56
  • Man, it won't let me format this any which way - or even link to an image. content.screencast.com/users/the_chrismo/folders/Jing/media/… !link attempt – chrismo Jan 15 '16 at 22:01
  • Darn, in that case the other option I would suspect would be hardware related to your MBP. I have seen similar issues where resetting the NVRAM can help (very similar to an SMC reset) - however if it continues after a reset, it may be specific to the ports. – andy_5860 Jan 19 '16 at 20:08
0

I have the opposite problem. My Thunderbolt display used to work fine but now displays only intermittently. However, its sound works fine and the laptop recognizes the monitor. Suspect fluctuating power screws up display; have tried various power cords and they sort-of work, then fail. I have a UPS/surge protection unit on order; have read others' posts and some have reported success with this.

  • Could you link to some of the other posts you're referring to? – jimmy0x52 Mar 27 '17 at 21:16
  • Searches for "thunderbolt display black flicker" etc. bring up many Apple forums. Sorry that's not more exact. The Apple Support forum posts where UPS success was mentioned tended to be newer (2015-16) though. Update: my UPS arrived today ... no dice. Have connection, have sound, but no display, just a black screen. I think this monitor is kaput. – Carolyn Rosner Mar 28 '17 at 23:20

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .