0

I have a MacBook Pro with OS X 10.8.5 and I have downloaded the wrong Safari browser, for OS X 10.10.

It says "You can't use this version of the application "Safari" with this version of OS X".

How to downgrade the incorrect version for OS X 10.10 and replace with the newest Safari for OS X 10.8.5?

1

From: Get the latest version of Safari for your Mac

You can keep Safari up to date by keeping macOS up to date.

Safari is included with your Mac. To get the latest version of Safari, install the latest macOS.

To keep Safari up to date for an earlier macOS, install the latest updates for that macOS.

Note: Updated to reflect changes in Apple Support HT204416 as of: Jun 15, 2017

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .