1

I'm running a MacBook Pro (Retina, 13-inch, Early 2015) with OS X El Capitan. I have an Arris DG1760 Cable Modem/Wi-Fi Router from Time Warner Cable. I connect to the router via Wi-Fi (5G). No issues until after my MBP goes to sleep and then I wake it up, I am still connected to Wi-Fi but have no connectivity whatsoever. I diff'd the result of ifconfig with a good connection versus after sleep/wake, and there is only one line different.

Working:

inet 192.168.0.8 netmask 0xffffff00 broadcast 192.168.0.255

Not Working:

inet 169.254.150.25 netmask 0xffff0000 broadcast 169.254.255.255

Apparently (from whois), the non-working IP is a link-local address. Not sure exactly what that means to my situation, but any ideas on how to resolve this? I'd prefer to not have to turn Wi-Fi on/off each time I come back to my MacBook.

  • I'm having exactly the same issue on a MacBook Air 13" 2012, did you ever find a solution for it? – Magnus W Jun 11 '18 at 9:10
  • Unfortunately I wasn't ever able to resolve this on that network. When I moved and switched to Verizon FiOS + Google WiFi the issue never came back. – hous Jul 2 at 18:16
1

I'm sorry I can't be of more help with the network diagnostics aspect of the issue, but you might try deleting out your wi-fi network and rejoining your network and/or renewing the DHCP lease (in your System preference pane for "Network" under the "Advanced" option).

1

Had very similar problem. After wake up Wi-Fi icon shows "connected" status, but network does not work, i.e. even ping to my router does not work. The connectivity usually resumes on its own after some time (dozens of seconds to couple of minutes), or after I do manual DHCP renew or turn Wi-Fi off and then back on.

The problem gone after I disabled DoS attack protection on my router. It seems that my router treated Apple's rapid DHCP (https://cafbit.com/entry/rapid_dhcp_or_how_do) as DoS attack attempt.

  • Give this man a trophy please. This made my day, I've been suffering of it for 2 years… – ronnieonrails Jan 29 at 18:13

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .