Yesterday I was doing some typing on my keyboard, when I found that I could not type a capital T with either shift key. I tried a different user account, and even rebooted into Snow Leopard (was using Lion) to no avail. I tried a USB keyboard, and it works fine. I don't understand what is wrong because the shift key still works, and the t key still works, just not at the same time. Any Ideas?

  • Check your keyboard setting in System Preferences. You might have it set to some non-English language. For example capitalizing an 'i' in Turkish doest produce an 'I' it makes an 'Í' or something like that. See Jeff's post for more info: codinghorror.com/blog/2008/03/whats-wrong-with-turkey.html Aug 18, 2011 at 2:31
  • 3
    What does shift-T do in Keyboard Viewer?
    – GEdgar
    Aug 18, 2011 at 2:39
  • @steve: it looks like it's a U.S keyboard. Are you talking about the input source?
    – thekmc
    Aug 18, 2011 at 10:27
  • @GEdgar: When I hold shift, I can't push t, and it doesn't highlight in Keyboard Viewer when I do.
    – thekmc
    Aug 18, 2011 at 10:28
  • Does option-shift-T work? Capslock-T?
    – GEdgar
    Aug 18, 2011 at 15:54

2 Answers 2


I did that once by accidentally setting an application hot key to be Shift-(and some letter key). Did you recently change hot key settings? If not, did you install something recently that may have had hot keys. If all else fails, try rebooting in Safe Boot Mode (hold down the Shift key on startup until the gear starts spinning), log in and see if you can type. When you are done in Safe Boot, restart w/o any keys.


It has mysteriously started to work again, along with two other problem keys, B and G (they worked with the right shift, but not the left). Thanks for all the help, and hopefully this doesn't happen again.

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .