1

I have installed a wrong version of Anaconda from python 2.7 on OS X 10.11.1 and to remove it, I deleted its files from the Finder.

Now Launchpad is confused and the Anaconda folder is still there, grayed and cannot be deleted using the mouse controls.

I do not know how to locate it in the Finder or Terminal to manually delete it. Any suggestions?

  • If you make a new user on the Mac, log out of the current user and then check Launchpad on the new user - is the ghost folder present? Or you could list more detail about what version of OS X and what version of anaconda - preferably with how you installed it and how you removed it - that might help as well narrow down what's broken. – bmike Jan 12 '16 at 14:46
  • I just created another user and logged in. The folder is not present in the new user's Launchpad. – Matin Kh Jan 12 '16 at 14:53
  • OSX version is El Capitan 10.11.1... I installed anaconda for python 2.7 (later I found this is the wrong version) and I tried to uninstall it by deleting it from application folder in the Finder. – Matin Kh Jan 12 '16 at 14:56
1

In the case where only one user has a "broken" layout, you might be able to wait until the system realizes the error and fixes it.

  1. Reboot
  2. Look in your user home folder for an Applications folder - check there or delete it if you don't use user applications
  3. As a last resort, view these various methods for clearing the database and settings files the dock makes to track the icons and organization of the LaunchPad: How to remove an icon from launchpad that does not appear in the Finder?

If you can drag the ghost folder from the launch pad to the dock (either in the applications section of the dock or the folders section), then locating the folder might be easier than messing with nuking the entire database or settings file.

sqlite3 $(find /private/var/folders -name com.apple.dock.launchpad 2>/dev/null)/db/db "DELETE FROM apps WHERE title='Anaconda';" && killall Dock
  • Reboot didn't work. The folder is still not present in user home folder (nor in Application folder). I am not able to move it to dock. It seems it is going to be there for a while! – Matin Kh Jan 12 '16 at 15:19

You must log in to answer this question.

Not the answer you're looking for? Browse other questions tagged .